Dwelvers Forum

Full Version: 0.9g2 - Room Wall Unfortified
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Sometimes when building a room, not all of the wall tiles get marked to be fortified.

[Image: 2989B.jpg]
I have to ask, are you sure you didn't reinforce this wall manually at some point and then removed it? Because then the game would think that you don't want this wall reinforced, and the only way to solve it is to do it manually.
That's a good question, but I had this happen a lot in 0.9g2 so I can't be 100% sure. So far I'm not seeing this occur in 0.1 not the other issue pop up with creatures leaving tasks unfinished. I haven't opened up the map in large swaths as I did with the one I reported this from so maybe that has something to do with it. I'll keep poking around to see.
Thank you Smile
Tried to reproduce this bug anyhow, but I couldn't, maybe you removed reinforce by mistake there? Sometimes it may happen.
Nah this was something that happened on more than one occasion
I've got another instance where this happened. The rooms were already placed. The long yellow line shows what length of wall I built. The arrows indicate where reinforcement didn't occur. You'll notice this even happened next to the DM room.

[Image: 2zvH2.jpg]
Hmm, Farm room fences blocks way to reinforce walls behind them, but at least these walls should be marked as to be reinforced by workers. I also had this bug once and also in the Farm Room:

[Image: r0quli.jpg]

I can't tell why exactly that happened, maybe because rooms and their building were built first and than path to reinforce were blocked so that cancelled somehow reinforce blueprint?
Well that would make sense for the Farm, but not the DM room. I tried several things to reproduce it, but mainly I wanted to try several schemes at the beginning of the level before there were any other jobs running so wall building and reinforcement was the only thing happening.

In all cases the wall was reinforced whether the room or the walls were there first. This leads me to believe that the task ends up getting canceled for some reason kind of like Imps leaving a job before it completes.
I found something that may have been causing this. If the player at some point select to reinforce the wall but then cancel it, then the wall will stay unfortified until the player decides to manually reinforce it again.

Version 0.11.10 released, this bug is solved but need confirmation!
Than that's solved.
Yeah, it looks to be. As long as I've played today I should've seen at least one occurrence, but never did.
Thank you Smile