Dwelvers Forum
Solved & Confirmed - 0.11.12 - Performance drops drastically when build bigger than 4x4 construction sites - Printable Version

+- Dwelvers Forum (http://forum.dwelvers.com)
+-- Forum: Community (http://forum.dwelvers.com/forumdisplay.php?fid=6)
+--- Forum: Archive (http://forum.dwelvers.com/forumdisplay.php?fid=28)
+---- Forum: Old Bugs/Issues & Crashes (http://forum.dwelvers.com/forumdisplay.php?fid=26)
+---- Thread: Solved & Confirmed - 0.11.12 - Performance drops drastically when build bigger than 4x4 construction sites (/showthread.php?tid=1844)



0.11.12 - Performance drops drastically when build bigger than 4x4 construction sites - Sebt - 01-12-2017

Well at least for me the performance dropped harder than Imps hit by lvl 7 Cyclotaur with his Bull Rush ability :v.
As you can see in the picture below from 12-16 fps that I normally have performance dropped to 2-3 when all of tiles on the picture below I marked together and got 3-5 fps when I divided both constructions sites on two.

Do you also experience such performance drop on your PCs? If yes that means either game is demanding when such big construction site is being made either my PC is too old (which shouldn't be the case because it works on normal payload) and that means changing minimal PC requirements could be raised up.  Shy

[Image: 25q57o0.jpg]



RE: 0.11.12 - Performance drops drastically when build bigger than 4x4 construction sites - Rasmus - 02-12-2017

Hmm, try checking disable rendering in the DEV TOOLS menu as well and compare the FPS with not having all the construction sites and when having them. Then I know if the issue is CPU related or GPU related.

Added to the list of Bugs/Issues & Crashes!


RE: 0.11.12 - Performance drops drastically when build bigger than 4x4 construction sites - Sebt - 02-12-2017

Disable rendering made everything to stop moving, but FPS was still 2-3, the same as having it enabled.

Since new graphics were implemented to the game I now can play on highest graphic settings for about 3-5 fps slower than before, but this I can blame my PC spec.


RE: 0.11.12 - Performance drops drastically when build bigger than 4x4 construction sites - Rasmus - 16-12-2017

Sebt, version 0.11.17 is now released and the issue you described with the frame rate going down when building > 4x4 constructions has now been solved. The issue was that buildings that could block the path for the creatures always should be built from the outside in so that they don't lock them self in. But the calculations I used for knowing what buildings to build first was very heavy, but that's fixed now.

Solved but need confirmation Smile


RE: 0.11.12 - Performance drops drastically when build bigger than 4x4 construction sites - Sebt - 16-12-2017

No frame rate drops in 0.11.17 when putting so large constructions site, it's resolved. Smile


RE: 0.11.12 - Performance drops drastically when build bigger than 4x4 construction sites - Rasmus - 16-12-2017

Thank you Smile