Solved & Confirmed 0.8i - Video scrolling causes blackouts
#1
I've noticed this a couple times before, and it only seems to happen when I have dug out a large area. When I scroll in any direction, part of the screen goes black and then returns to normal shortly after like so:

[Image: TGij.png]
Reply
#2
I believe this is because the camera culling (what is visible by the camera or not) is being updated on a separate thread. If the camera moves to fast, the camera culling thread can get behind and calculate what is visible or not for a previous camera location.

I can't say that it is 100% so, but if it is it should apply to when the camera is rotated as well.
Reply
#3
What can you say about this bug?
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
Reply
#4
I can say that I've played a good bit in 0.8j2 and I'm not seeing this at all anymore. This was happening quite a bit especially when I sped the game up and there were a lot of resources on the ground, but so far so good.
Reply
#5
OK, I'll mark this as solved then. Thanks. Smile
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
Reply
#6
Hate to go back on this, but after a really huge excavation and while running the game on max speed, I noticed the edges going black while I scrolled like before. It's nowhere near as bad as before, but it is still there.
Reply
#7
I can imagine that this issue will be harder to reproduce with the next version as the resources on the ground has chunked together and therefore don't demand as much CPU usage as before.

But the issue can still arise at some point I believe. I am curious what you have to say about the upcoming version so I will set this as solved with the next version Smile
Reply
#8
Oh let me get 140+ Imps digging up the entire map and see what happens. Looks like the next version may be coming up soon with all your bug bashing the past few days.
Reply
#9
Dwelvers version 0.9 released, this bug is solved but need confirmation.
Reply
#10
I think we'll need to wait until the Storage Loop issue is resolved first. It's kinda hard to see if your backpack method is going to resolve this issue without proper storage.
Reply
#11
Gotya, I will just let this one be until the next version is released.
Reply
#12
Hmm, so 0.9c came and is this issue still alive?
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
Reply
#13
Yup, even worse now with the performance issues.
Reply
#14
Back to unsolved!
Reply
#15
So the performance issues are solved with the next version. Hopefully this issue with it. Solved with the next version!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)