Solved & Confirmed 0.9 - Creatures float over 1 block holes when going beyond it.
#1
If a creature is going somewhere and has to walk pass a 1 block hole, it will hover it instead of dropping down and climbing up again.

[Image: dfivDbT.jpg]
(Notice how the imps candle light trail is straight)
Reply
#2
Added to the list of Bugs/Issues & Crashes!
Reply
#3
I thought I saw something similar to this when I excavated a large area, but I wan't sure. I coulda swore I saw an Imp fly from the top layer down into the excavated area.
Reply
#4
Solved with the next version!

Almost related Wink


Reply
#5
OMG, where'd you find this?!
Reply
#6
Haha, I have seen it before Tongue
Reply
#7
Dwelvers alpha 0.9b released, this one is solved but need confirmation!
Reply
#8
I just noticed that the floor tiles in that image are claimed tiles and not roads.

I tried to reproduce the conditions, and didn't notice the drop being ignored so that they pass over an empty tile on the same plane. I did spot my flying Imps this time for sure though. I tried to reproduce those conditions, but couldn't get one captured on video. I noticed that when there were a bunch of Imps using the same path that went down the ladder to the build site, but 2 Imps ignored that path. Instead, they flew down to where the X mark in this image is. The yellow line indicates the path they took.

[Image: YbWF.jpg]
Reply
#9
So you are saying that there is a chance (not every time) that the imps will jump down a ladder instead of climbing down, and when there are no ladders everything works as it should?
Reply
#10
Well, I wouldn't say they jump down the ladder because they don't go straight down. I've only seen this twice and not sure exactly how to reproduce this one, but like the image above shows they kinda just flew down to the lower tile in a curved fashion.
Reply
#11
Thanks to David Bacuvka for finding this one. I wonder how much ladders play a role in this, but there again I haven't had as much time lately to dedicate to Dwelvers to really dig into it. Thank goodness we have a great group of members that can help contribute.

I took the image he posted on a separate thread, resized it, and here it is:

[Image: YSPi.jpg]
Reply
#12
Hmm, so I will fix the ladder bug. If this solves your issue as well Mello we can mark this one as solved.
Reply
#13
I hope to have some time this week to take a look, but the problem is that I've not quite determined what conditions cause Imps to ignore the ground. I think paths with ladders leading to a construction may be the link, but I really haven't had any time to delve into it.
Reply
#14
Ladder bug seems to be solved, so is this bug too?
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
Reply
#15
It's still here in 0.9d:

[Image: Zzj6.jpg]
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)