Nick:  
Pass:     
Help Register


Post Reply 
Solved within development process 0.9e-5 - New Crash
Author Message
Xaos Offline
Digger of the depths

Posts: 92
Joined: Aug 2015
Reputation: 8
Post: #1
0.9e-5 - New Crash
Got this randomly after a long play session:

Crash Report: Dwelvers Alpha v0.9e-5
Running time: Hours: 4 Minutes: 39 Seconds: 5

____THREAD 1____
D3DRender2DLayer::RenderQueue
D3DDrawable::RenderTextured2DTriangles
D3D::UtilSetShaderResources


____THREAD 2____
Game::StartLoopThread
Game::Loop
Game::Render
D3D::Start
D3DPresenter::PresentWait


____THREAD 3____
Game::StartThreadRender3D


____THREAD 4____
D3DCamera::ThreadCameraFrustrumCulling


____THREAD 5____
GameLevel::UpdateGameLevelDuringRenderingThread


____THREAD 6____
GameLevel::UpdateGameLevelDuringRenderingThread


____THREAD 100____
GameLevel::ThreadUpdate
(This post was last modified: 08-09-2015 08:09 AM by Rasmus.)
06-09-2015 06:01 AM
Find all posts by this user Quote this message in a reply
Rasmus Offline
Main developer of Dwelvers
Dwelvers Developers

Posts: 3.782
Joined: Sep 2013
Reputation: 504
Post: #2
RE:
Seems related to when a triangle was going to be drawn. It may be a threading problem where two threads tries to access the graphic card at once. I have seen other crashes in the exact same location.

Added to the list of Bugs/Issues & Crashes!

(08-09-2015 12:33 AM)Xaos Wrote:  Crashing a lot on me lately. Usually near endgame. This one was shortly after I loaded a save game.

Crash Report: Dwelvers Alpha v0.9e-5
Running time: Hours: 0 Minutes: 6 Seconds: 6

____THREAD 1____
D3DRender2DLayer::RenderQueue
D3DDrawable::RenderTextured2DTriangles
D3D::UtilSetShaderResources


____THREAD 2____
Game::StartLoopThread
Game::Loop
Game::Render
D3D::Start
D3DPresenter::PresentWait


____THREAD 3____
GameLevel::UpdateGameLevelDuringRenderingThread


____THREAD 4____
D3DCamera::ThreadCameraFrustrumCulling


____THREAD 6____
GameLevel::ThreadUpdate


____THREAD 12____
GameLevel::UpdateGameLevelDuringRenderingThread


____THREAD 23____
Game::StartThreadRender3D
(This post was last modified: 08-09-2015 08:12 AM by Rasmus.)
08-09-2015 08:07 AM
Find all posts by this user Quote this message in a reply
Rasmus Offline
Main developer of Dwelvers
Dwelvers Developers

Posts: 3.782
Joined: Sep 2013
Reputation: 504
Post: #3
RE:
Because of this bug being so old and no new reports has been made I move it to the "Old Bugs/Issues & Crashes", if this issue arises again a new topic should be made.
15-03-2016 10:54 AM
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)


© 2013-2017 Dwelvers | Contact