Solved & Confirmed 0.11.1 - OpenAL error after closing the game & not hidden system cursor after start
#1
Error!
Function:
SoundManager::_StartThread

Message:
Error unqueueing OpenAL buffers!
ErrorID: 40964
Internal source id: 0
OpenAL source id: 1

Stack trace:
3 0
2 BaseThreadInitThunk 1956067536
1 RtlUnicodeStringToInteger 2002672576
0 RtlUnicodeStringToInteger 2002672576


After re-starting the game again I got this at the start:

Function:
CheckErrorLog

Message:
This program was unexpectedly finished last time it ran.

Error type: Error!

Message body:
Function:
SoundManager::_StartThread

Message:
Error unqueueing OpenAL buffers!
ErrorID: 40964
Internal source id: 0
OpenAL source id: 1

Stack trace:
3 0
2 BaseThreadInitThunk 1956067536
1 RtlUnicodeStringToInteger 2002672576
0 RtlUnicodeStringToInteger 2002672576



Stack trace:
5 0
4 0
3 0
2 BaseThreadInitThunk 1956067536
1 RtlUnicodeStringToInteger 2002672576
0 RtlUnicodeStringToInteger 2002672576


Then nothing strange happened except that system mouse cursor is still visible as well as game cursor as in main menu as in the game:

[Image: 24bnqko.jpg]

I will not get this message if i crash the game clicking on Resume - known bug -> 0.11.1 - Crash on resuming the game
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
Reply
#2
I've seen this issue before during the development but thought I solved it :/
Added to the list of Bugs/Issues & Crashes!
Reply
#3
Yeah... It's still in 0.11.2 BT version BTW.

EDIT: In 0.11.3 BT I also got Runtime error after getting launcher error message.
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
Reply
#4
New version released, this bug is solved but need confirmation!
Reply
#5
Previous was fixed, but a new one appeared, this time with different source id, appeared after I quit the game not starting a new one, from main menu just after launching the Dwelvers (Windows mouse cursor is also visible after restart):

Error!
Function:
SoundManager::_StartThread

Message:
Error unqueueing OpenAL buffers!
ErrorID: 40964
Internal source id: 16
OpenAL source id: 17

Stack trace:
3 0
2 BaseThreadInitThunk 1956067536
1 RtlUnicodeStringToInteger 2002672576
0 RtlUnicodeStringToInteger 2002672576



After playing for about 20 minutes I wanted to quit the game and it seems the same error appeared:

Error!
Function:
SoundManager::_StartThread

Message:
Error unqueueing OpenAL buffers!
ErrorID: 40964
Internal source id: 0
OpenAL source id: 1

Stack trace:
3 0
2 BaseThreadInitThunk 1956067536
1 RtlUnicodeStringToInteger 2002672576
0 RtlUnicodeStringToInteger 2002672576
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
Reply
#6
Ok, thank you Smile
Back to being unsolved!
Reply
#7
Ok, so I couldn't reproduce this issue myself. But I made some changes in the way sounds now are cleaned up. What is causing this bug is that when a sound channel gets cleaned up (Dwelvers have 32 sound channels meaning that 32 sounds can be played at once) it throws this error that you are getting. So what I did was to clean up a sound channel before it plays a new sound, instead of just cleaning up the sound channels when you close the program.

I think this is the was I should do it. But if the problem remains there are a risk that you will be getting this error during game play as well and not just when you close the game. Lets just hope note :/

Solved with the next version!
Reply
#8
Version 0.11.5 BT released! This bug is solved but need confirmation!
Reply
#9
It's solved. Smile
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
Reply
#10
Thank you Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)