Solved & Confirmed 0.11.7 BT - Game turns into windowed mode at the launch and after doing Alt+Tab
#1
As the issue in Alt+Tab "throws flashbangs" at your face and runs the game in windowed mode now is solved, something that is related to switching between game and desktop and still shows a white plane for a short time.

First white plane shows when game is being launched from Dwelvers launcher - game goes first to the windowed mode and shows white background for few seconds till the game start - see animation below:

[Image: 2zEoj.gif]

There's also one white flash bang for a split second when I switch from the game to desktop with Alt+Tab (video capture program couldn't capture that this time), also game turns again to windowed mode like during launching the game. So this is what can you find in the window preview:

[Image: 2m4dbes.jpg]

Interesting is that when I want to go back to the game no white flashing appears, it behaves normally.

Maybe this white plane has to do something with this DXGI error I mentioned in the linked in the first paragraph of this post? This error is still present, but not game breaking, it only prevent game to go fullscreen, but after doing Alt+Tab twice I can play again the game in fullscreen mode.
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
Reply
#2
Added to the list of Bugs/Issues & Crashes!
Reply
#3
Dwelvers Alpha 0.11.8 BT released with fixes related to the fullscreen bugs. I now use "fake" fullscreen where the window is borderless and gets resized over the whole monitor.

This bug is solved but need confirmation.
Reply
#4
Nice, switching between desktop/other apps and the game now looks very smooth and the game closes much faster. I still get some white flash before Dwelvers logo shows after launching the game and when I return to the game from desktop/other apps, however this time the white flash is very very short, almost unnoticeable, so it may look like it sometimes appear sometimes not.

Do you experience that playing latest version like me? Here's the example:
First flash before Dwelvers logo, next flash was the second time I switched windows with Alt+Tab

[Image: 2zFtj.gif]
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
Reply
#5
Hmm, I'm not to happy either about that the menu background gets the wrong aspect ratio :/
I'm sure I can fix the flashing. It's probably just the background color of the window that is shown before the first frame gets drawn.

Back to being unsolved.
Reply
#6
Well I think you can mark this issue as solved and confirmed. I had never got any white screens in 11.9 version. Game just goes straight to fullscreen mode. Smile
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
Reply
#7
I've fixed the aspect ratio issue as well Smile

Version 0.11.10 released, this bug is solved but need confirmation!
Reply
#8
Confirmed. I see you gave two screen size option, but I always choose with no boundaries because it looks the best and game launch a little bit faster.
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
Reply
#9
Yeah I thought it was necessary, because I'm pretty sure someone will have complaints about the borderless fullscreen as well. Actually the v-sync option works a lot better when running it in true fullscreen, but on the downside you can't have a windows drawn cursor then which makes the cursor a little bit less responsive.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)