Solved & Confirmed 0.6c - Problem with "d3d11.dll not found"
#1
when i go to start the game up its says d3d11.dll not found to i reinstalled it and it still says it so i reinstalled directx and it till says it so i need help with fixing this
Reply
#2
Do you have a Direct3D 10+ compatible graphiccard?
What OS are you using?

And just to be sure, here is the link to directX redist:
http://www.microsoft.com/en-us/download/...px?id=8109

And welcome to the forum Smile
Reply
#3
im using navidia geforce 9200 that on the control panale it has 3d settings and im using windows vista
Reply
#4
Hmm, I seem to remember having a similar error back when I was testing the 3 or 4x versions of the game. It came down to a missing file that may or may not be on a computer and Rasmus had to include that file with the download to make sure it was available to, then it was called Dwelvers, so I'm wondering if a similar sort of fix would help here, maybe a missing d3d11.dll patch could help for anyone who gets this sort of error?
[Image: 11619898803_7d3a89e6bd_n.jpg]
The Golden One!
Reply
#5
Nividia G9200 should have DirectX10 so I think the issue is with the OS. You need Windows Vista SP2 or above, that is the first OS that supported Direct3D10.

So my only solution to this is that if d3d11.dll don't get installed on your OS when you run the DX redist package I linked to you above I think your OS don't support Direct3D10. There is a specific update with windows Vista SP2 that makes it possible to run direct3D 10+ games on your OS, and my guess is that you don't have that update installed. The best link I could found on the net that could solve this issue is this one:
http://www.ngohq.com/news/16601-how-to-i...vista.html
Reply
#6
i have the sp2 installed
Reply
#7
Do you have d3d11.dll on your computer, maybe you can do a quick search? Because this is an issue with installing DirectX on windows, not a bug in the game.
When searching on google I can see a lot of issues with Windows Vista and installing DirectX10, I would love to help you here but I can't because the issue lies with that you aren't able to install DirectX10 on your operating system, the game would accept it if you had it installed.
Reply
#8
Sometimes even though you have DirectX installed on your system, some of the components may be missing. You should try first to update DirectX by downloading it from Microsoft. You can try this page first: http://www.microsoft.com/en-us/download/...aspx?id=35. If you still see this error then try this: http://www.microsoft.com/en-us/download/...px?id=8109.

Hopefully one of those will correct your problem. I had this issue on one of my Windows 7 machines and the first link fixed the problem.
Reply
#9
its fixed now but i didnt know how laggy it was but thats not og this thred
Reply
#10
(28-01-2014, 06:24 PM)bluewolf194 Wrote: its fixed now but i didnt know how laggy it was but thats not og this thred

It will get better Wink
Reply
#11
I also experienced this with a nearly brand new computer: Windows 8, Intell HD GFX Family Card.

The suggested fix worked for me with the same problem. Thanks Ras!
[Image: i563hs.png]
No Money, No Poverty, No Crime, No Politicians, No Corruption, No Social Stratification, Strength Based Education, Global Democracy, and True Equality.
A New Social Paradigm: Only Impossible Because of Your Attitude; Only Possible with Your Aspiration Towards a Better World.
You can't spell Humanity without Unity.

Reply
#12
Welcome to the forum TacticBlack Smile
Good to hear, thanks!
Reply
#13
I'm having the same problem but it says "The program cant start because d3dx9_43.dll is missing from your computer. Try reinstalling the program to fix this problem." I tried what you said but it still says that


Ok Now its saying "The application was unable to start correctly(0xc000007b).Click OK to close the application."
Reply
#14
What OP system and graphic-card do you have? Windows Vista?
Reply
#15
Windows 8 and im not certain about the graphics card.
ITS RALLY PISSING ME OFF!AngryAngryAngry
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)