Dwelvers Forum

Full Version: 0.11.2 BT - Lighting affects tile selection for digging multileveled terrain
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Sometimes when you do some tile selection to dig some rocks and behind these selection there is an area that contains different terrain levels game selects much more tile to dig than your mouse during selection could mark. This extensional marking may be affected by new lighting system because when this happens some part of dungeon gets dark a little:

Normal selection of tiles to dig:

[Image: 34gudxy.jpg]


Abnormal selection that games forces on me with shadowy effect - look at where is the cursor:

[Image: 2d6k3fd.jpg]
Added to the list of Bugs/Issues & Crashes!
I solved this by removing the new lightning effects when the textures were being highlighted.

Solved with the next version!
Version 0.11.5 BT released! This bug is solved but need confirmation!
It is almost solved, the only thing that selects tiles like this is when your pickaxe touch the border of tech screen:

Here mouse is on the bottom left of the screen and I only marked 1 string of tiles close to my dungeon walls.
[Image: 2cwtl4k.jpg]
Hmm, ok. It is a different bug I think, related to the other one reported that the selector got missplaced when selling.

I will make this one unsolved.
I can't reproduce this, does it select everything to the left every time you hover the tech screen? Or was it just something that happened once?
When you pull mouse while selecting tiles - for example from up to down - and you go with selection so far that it will make edge scrolling the map this strange selection happens - when you stop scrolling down the map, this "over-selection" gone.

Maybe you're unable to reproduce this bug because... it may be related to an issue when you can see water under FoG, but have never discovered these areas? This bug happens only if selection will encompass also undiscovered area of different terrain high, not the same.
Check if it is solved now, I think it had something to do with that the mouse cursor went outside the window somehow when doing edge scrolling. And with this version I fixed a but that sometimes made windows enlarge the game window because of the windows DPI settings.

Solved but need confirmation.
Yeah it's solved. Smile
Thank you Smile