Dwelvers Forum

Full Version: 0.11.2 BT - Room Constructions Against Walls Won't Complete
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I saw this in a previous game on this version, and didn't notice it again in this second one until all my creatures were complaining about food. I had created 2 tables connected that attached to the wall, and neither were being built. I removed the one directly adjacent to the wall, and the other table was built. I replaced it and as you see below, it is still incomplete and will remain that way.

[Image: 2znPX.png]
Have you tried to save and load the game to see if suddenly these were starting to be built? I had similar issue that I've described here.
Yeah, reloading did get those to be constructed
I think this one is solved together with this bug: http://forum.dwelvers.com/showthread.php?tid=1799
New version released, this bug is solved but need confirmation.
I'm not sure, there are still some TYPE of beds or mills that were still not built like at some time of playing the game from start someone steals tasks to make specific group of room buildings.
Ok, I will put this one back to not solved and have a closer look at it Smile
Okay so I've been doing some changes on the code and I solved a issue that I found that seemed related to this one. So I hope this one got solved as well Smile

Solved with the next version!
Version 0.11.5 BT released! This bug is solved but need confirmation!
I believe this one is fixed. It was very easy to reproduce as I always build a staging area with all the core rooms built next to each other and then I dig out the floors for resources and start building rooms once I fill back in. At every new game, at least one of the constructions would fail to be completed until I saved and reloaded. I didn't see that happen on my new 0.11.5 BT game
Thank you Smile