Dwelvers Forum

Full Version: 0.11.3 BT - Direction issues during object rotation
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Some room devices contains arrows when rotated tells the player where workers will operate them. However as most objects have these arrows pointing in the same direction as you move the mouse, than some other objects behaves different (on red I marked from where I was starting pulling mouse cursor to rotate objects):

Farm Room Mill:

[Image: egsuom.jpg]

Sewing Machine:

[Image: 6yejb8.jpg]

Sarcophagus. It doesn't contain side arrows, but when I try to rotate already set blueprint it behaves like I was doing selection of wall tiles:

[Image: 2m6rd6f.jpg]
Added to the list of Bugs/Issues & Crashes!
This was a weird bug. So the buildings could have a property called "inverted rotation", which no building used... But still the property was there. But it wouldn't make any difference because if no one uses the property it should be set to false... But this wasn't the case either, I had forgotten to initialize the property and give it the value false from start, and the thing about c++ is that if you don't initialize a variable with a value it can be given any random value. So some buildings had a inverted rotation value and some buildings didn't. It was all random.

This bug was solved by adding one line of code. But it took me an hour to know that it was so simple.

Solved with the next version!
Version 0.11.5 BT released! This bug is solved but need confirmation!

Edit: Rotating placed blueprint catacombs cause game... to crash. o.o
What's even more fun that crash reset keys settings to default. O.o
I think that's a curse of undead... O.O
Hmm ok, I will check it out. And get back to this post later.
Sure thing.
Because we have another bug report handling the crash issue I will set this as solved and confirmed.
Well, there are some objects that still have the original issue with how rotation is showing when you choose any to built from radial menu:

- stone fence, wall lantern, wall manacles - whatever direction you choose they show its blueprint in only ONE orientation - upper side, however if you pull for example to the left and place the fence like that it will will be directed towards right side - reverse orientation.

- stairs, painting, insignia, prison wall skull - they're wall decorations, but you can choose direction for them at all directions. Also pulling mouse for example to the left shows it will be placed to the right - however if you put them next to the wall they will be built on this wall (like they should, so it's good), no matter what direction you choose - but regarding what I said earlier maybe choosing orientation of these objects should only show directions of the only walls they actually can be placed, not all four directions?

- prison hand torch, farm gate - pulling mouse for example to the left shows it will be placed to the right.

- training room dart board - like in case for stone fence etc. whatever direction you choose they show its blueprint in only ONE orientation - moreover in case of dart board when trying to place it in the corner (two possible walls to put it) -  it will show wrong selection orientation of this object selection only for direction of upper wall (so this that is only showed during selection orientation for new dart board), all other directions selection locations are showed correctly (), see below:

Mouse pulled up or to the bottom of the screen, shows inverse selection (you can't see mouse cursor because for this picture I had game started with Windows cursor marked in launcher):
[Image: 30cpuae.jpg]

Here dart board was placed mouse was pulled to the left, but blueprint preview showed it will be placed on upper walls not this to the right. Selling selection is correct:
[Image: 25uo1zc.jpg]
Hmm, as that issue is reported here and is more specific to that issue I will keep this issue as solved and confirmed.

I know about the rotation issue but as it will take a couple of hours at least to solve and it is far from game-breaking it has been put on hold, but I will solve it soon Smile