Dwelvers Forum
Solved & Confirmed - 0.8k-2 - Adjacent Ladders Fail Construction Path - Printable Version

+- Dwelvers Forum (https://forum.dwelvers.com)
+-- Forum: Community (https://forum.dwelvers.com/forumdisplay.php?fid=6)
+--- Forum: Archive (https://forum.dwelvers.com/forumdisplay.php?fid=28)
+---- Forum: Old Bugs/Issues & Crashes (https://forum.dwelvers.com/forumdisplay.php?fid=26)
+---- Thread: Solved & Confirmed - 0.8k-2 - Adjacent Ladders Fail Construction Path (/showthread.php?tid=1397)



0.8k-2 - Adjacent Ladders Fail Construction Path - Mello Tonin - 23-03-2015

When I build lairs for Impanzees, I like to make them with different height levels and recently with ladders since apes like to climb. I noticed this time as I was placing the lair tiles that the game lagged real hard. I sped it up thinking maybe something was stuck somewhere and it would work through and my constructions would be built. That never happened. I verified the path visually and with dev tools, and there wasn't a problem. Below is an image of my first steps to correct:

[Image: VaCq.jpg]

You will notice the adjacent ladders circled in yellow, and this is where pathing should work, but doesn't. Where the red X is, I sold this ladder and built a single tile. Presto! My lairs are being built and beds added. Well all but one. You'll see in this image I have the same thing going on with the ladders. The lair was built before I dug out the room prior to the issue, but you'll see the bed not built. This also shows the progress after I placed the tile pointed out with the blue arrow where a ladder once was from the previous image.

[Image: VaCr.jpg]

Here is my Save Game so you can go through the same process. It is saved prior to the steps I took to fix.


RE: - Rasmus - 23-04-2015

Added to the list of Bugs/Issues & Crashes!


RE: - Rasmus - 28-04-2015

This one was really interesting, I am really impressed that you noticed it Big Grin

I managed to simplify the issue a little with the dev tool "Show walkable for player". When selecting this you will see in the following screenshot that the path up and down the ladder is missing. But the thing is that this only happens when there are another ladder built above like in the screenshot.

[IMG]replace_photbucket_link/BugLaddersBuiltOnTopOfEachother.png[/IMG]

Hopefully when this path finding issue is solved it will stop lagging.


RE: - Rasmus - 28-04-2015

Solved with the next version. The issue was that if a ladder is built on a tile, then it will not accept ladders leading to that tile.


RE: - Rasmus - 09-06-2015

Dwelvers version 0.9 released, this bug is solved but need confirmation.


RE: - Mello Tonin - 10-06-2015

This one is solved.


RE: - Rasmus - 11-06-2015

Thank you!