The following warnings occurred:
Warning [2] Undefined variable $unreadreports - Line: 66 - File: global.php(961) : eval()'d code PHP 8.0.28 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/global.php(961) : eval()'d code 66 errorHandler->error_callback
/global.php 961 eval
/printthread.php 16 require_once
Warning [2] Undefined property: MyLanguage::$archive_pages - Line: 2 - File: printthread.php(287) : eval()'d code PHP 8.0.28 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/printthread.php(287) : eval()'d code 2 errorHandler->error_callback
/printthread.php 287 eval
/printthread.php 117 printthread_multipage

Dwelvers Forum
Solved & Confirmed - 0.7e - The elusive floating root - Printable Version

+- Dwelvers Forum (
+-- Forum: Community (
+--- Forum: Archive (
+---- Forum: Old Bugs/Issues & Crashes (
+---- Thread: Solved & Confirmed - 0.7e - The elusive floating root (/showthread.php?tid=1442)

Pages: 1 2 3 4

0.7e - The elusive floating root - Excess - 20-07-2014

Ok, I've been seeing this bug at least from 0.7a, but I never took the time to grab some screens and post it, as it's really rare.

Basically, a random root moves away some 9/10 blocks from it's supposed position, but continues to grow like its siblings, only floating somewhere else. The root block which it belongs, is the one directly above the leftmost baking table. If I sell that square, the floating root disappears.

[Image: fW57XMM.jpg][Image: bzdiK2W.jpg]

Also, while I was taking the above screenshots, it disappeared only to reappear somewhere else...

[Image: PdGnzHZ.jpg][Image: Pl5uY24.jpg]

Here is the save file.

RE: v0.7e - The elusive floating root - RestOne - 20-07-2014

Got the same bug, a few times already, but never captured it with such detailed screenshots^^

RE: - Sebt - 01-08-2014

Hmm, interesting bug that somehow was missed on the forum. Added to list of Bugs/Issues & Crashes. Smile

RE: - Rasmus - 02-08-2014

I have to say, this must be the weirdest bug ever Tongue

Okay, it will be a challenge finding the issue. In worst case I will rewrite the code where the root is rendered.

RE: - Marcus Ljunggren - 09-08-2014

hehe funny

RE: - Rasmus - 22-08-2014

I will have to put this one in more reports needed. I have not been able to reproduce the bug, and I can't figure out why the root starts flying away. But as I understand this bug isn't game-breaking so I think we can let it be until later. I figure that I will bump in to it at some point in the future and then I can fix it.

Hmm... Maybe we can do a competition about it. The first person that manage to record this bug will win a free copy of Dwelvers Big Grin

RE: - Mello Tonin - 22-08-2014

Yeah this one is really random. I've only noticed it once, and it was only after reading this thread. I should've taken screen shots. Most of the time I'm all over the map and not focused on my farm area.

0.8b - Bug/Issue - Flying Antroot - Ardilor - 02-09-2014

Another glitch in animation, it's only visual and doesn't affect the game. It disappears, when imp collects antroot from block beneath flying antroot.

[Image: 2cnxcow.jpg]
[Image: slpd34.jpg]

RE: - Rasmus - 02-09-2014

I don't know if I wanna fix this, it is too funny Big Grin

RE: - Sebt - 02-09-2014

That's a new dungeon living being, maybe we should mark it as not a bug, but feature? Big Grin

RE: - Mello Tonin - 04-09-2014

The Elusive Antroot

[Image: KkTU.png]

L I V E S ! ! !

...and look who's there, it's Flappy the Bat...up to no good as usual.

...maybe not so elusive; I found another example on another map.

[Image: KkUg.png]

RE: - Sebt - 04-09-2014

Definitely confirmed by others that bug apply to everyone, I changed status to Not solved yet.

RE: - Rasmus - 04-09-2014

From now on we blame everything on Flappy Big Grin

RE: - Mello Tonin - 04-09-2014

Yes, Flappy is a ROUGE!

RE: - Sebt - 05-09-2014

It's good to be bad though.