Solved & Confirmed 0.7e - Crash during change armor of the orcs
#1
Hello,
I have this crash when i change armor of the orcs or of the imps.


Attached Files
.txt   DwelversCrash114-6-10-22-36-29.txt (Size: 19,89 KB / Downloads: 4)
Reply
#2
Hi Burtis, welcome to the forum Smile

Is this crash reproduceable for you?
Did you get an error message with the crash?
Reply
#3
This crash was reproduced several times when i reloaded my save and did the same action.

There was an error message, but I did not notice. If i have this crash again, i will make à printscreen.
Reply
#4
Even better.. Could you send me your savegame? Just compress it and attach it Smile
Reply
#5
Anyone else experienced this crash too?
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
Reply
#6
Added to the list of Bugs/Issues & Crashes
Reply
#7
   

i think the problem come when i took armor in a storage or during a move between two storages.
Reply
#8
i saw that error message a few times too
but it did not crash ( i pressed ignore )
i got that message when trying to put a shield in an empty hand i think
Reply
#9
I think this one goes hand in hand with http://forum.dwelvers.com/showthread.php?tid=951

Either way, thanks for the report. I think I have enough info to fix it Smile
Reply
#10
This one is now solved!

This bug is very reproducible, what you do is transport a specific armor or weapon type to another storage room, when this is done all these items will get a job attached to them that tells the workers that they are available for pickup. Then you equip a creature with any of these items you transported. This is where it goes wrong, I forgot to remove the pickup job for the item when a items is equipped by a creature. So when the worker tries to pick up the non existing item the storage building complains about that it doesn't recognize the item the worker is about to pick up. Thereby the error!
Reply
#11
This is now reported here for v0.8b.
Reply
#12
Yeah, same bug, but I believe what is causing the bug are different now. Anyhow... I will put this one as unsolved and list it under the same bug. I don't have Sebt's merging skills Tongue
Reply
#13
Solved with the next version!
Reply
#14
New version released, can anyone confirm that this bug is solved in the 0.8c version?
Reply
#15
seems to be fixed
i had it crash on me with this in "b" and i equiped multiple creatures in "c" without problems
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)