Solved & Confirmed 0.7e - Confused Orcs in Trainingroom
#1
Hiho

Some Orcs are confused in the Trainingroom when the door are open.
If i close the door, the orcs continue the training and all is fine..should be rather the opposite.
In the Barroom food is available.

To understand what i mean



Reply
#2
That jittering/shaking behavior has something to do with the decision making process or pathfinding of the orcs.

I've too noticed them doing it on the training room in between pig-hits.

The same thing happens, only way worse, when an orc founds an enemy they can't reach, like a fishmen in a cliff 2 blocks below. There's clearly no path available to them, not even the enemy is moving due to this fact, but the orcs get all jacked up and want to get violent in vain.

[EDIT]

Made a gif of the jittering...

[Image: ASzarif.gif]
Reply
#3
Added to the list of Bugs/Issues & Crashes
Reply
#4
This one is solved. There was some confusing about what jobs the creatures were able to take on when they are hungry. The training job took the orc to the punching pig, but once the orc got there he didn't want to train because he was hungry, so he started walking towards the bar, but when he got out of range from the training pig the training job dragged him back in again.

Now the creatures won't train at all if they are hungry.
Reply
#5
These creatures are definitely confused. I'm not sure if it is they can't figure which dummy to hit, or there are too many creatures trying to use the same dummy. You'll notice in the video link below that they do react to a Rally Flag and when a dummy is sold. I put up walls later after they had been stuck for a while to test the 'Orcs confused when door is open vs locked' issue.

Reply
#6
Back to unsolved!
Reply
#7
I went back later and added more training dummies, and that seemed to unclog the grouping in the Training Room. I wonder if my assumption was correct that multiple creatures were trying to use the same dummy and getting stuck.
Reply
#8
Solved with the next version (I hope), I haven't had the time to test every option.
Reply
#9
New version released, can anyone confirm that this bug is solved in the 0.8c version?
Reply
#10
I believe this one is now fixed. I reduced the number of training dummies, and instead of them all clustering up in one location, they may stand in place for a bit, but then move on when there isn't an available dummy to bash.
Reply
#11
Is there anyone else that could confirm this big as solved? Smile
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
Reply
#12
I believe this one is good now. Everyone seems to be taking their turns on the training dummies without getting stuck in place as before.
Reply
#13
Anyone else could agree with Mello this bug is solved? Smile
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
Reply
#14
Okay, I will put this as solved. The other issue with confused orcs in the training room is that they don't hear the rally flag while training, but that is already reported in another topic.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)