Solved & Confirmed 0.8b - Hanging on load
With threading unchecked, the game hangs while loading. With threading checked, the game gets to the main menu but hangs while creating a game. I've left it sitting for 10 minutes just to make sure it wasn't simply taking a long time but it just sits there at the "creating game" screen. The music cuts out after a couple of minutes.

Not very useful information but the game isn't crashing so i have no crash report.

EDIT: The game ran fine for me on 0.7e
Actually, can you run it with threading and with the debugger running, and when it hangs just ctrl+alt+del it, then some useful information should come up in the debugger.
Another question, what CPU do you have?
Crash report:

My CPU is an AMD Athlon II X2 260 3.2GHZ

EDIT: Sorry, that was run without threading. Uploading another crash report in a minute.
Crash report with threading enabled:
Thank you Smile
The issue is that Dwelvers uses as many threads as the computer has cores, this is because I don't want to use to many threads as that can make the game slower. The issue here is that I use a minimum of two threads, this was enough before this update, but in this case the loading requires more threads. The AMD Athlon II X2 260 3.2GHZ is a dual core processor, which means I only enable two threads.

I usually get technical when explaining the solutions, some of the members here like it because it gives a deeper understanding on how the game works in depth, you can ignore this if you are not interested Wink

I am not 100% it will work with this solution, but I do think this is the cause.

So here comes the detailed explanation on this issue:

Thread A starts Thread B and Thread C.
Thread A waits until Thread B has finished.
Thread B wait until Thread C has finished.
The problem is that if the game has set a limit on only making 2 threads at a time, then thread A and B will be created, and thread C will not be created until either thread A or B has finished. And Thread B will not finish until C is finished, and A will not finish until B is finished... So all it does is wait...

I am not saying that it works like this all the time, but this situation can come up where all the threads needs to sync before continuing. And I believe that is the problem here. At least I hope that is the problem Smile
New version released, can anyone confirm that this bug is solved in the 0.8c version?
I can confirm that i can now successfully start a game with or without threading enabled.
Thank you!
Good to hear, this bug made me sweat a little Tongue
Thank you Smile

Forum Jump:

Users browsing this thread: 1 Guest(s)