The following warnings occurred:
Warning [2] Undefined variable $unreadreports - Line: 66 - File: global.php(961) : eval()'d code PHP 8.0.30 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/global.php(961) : eval()'d code 66 errorHandler->error_callback
/global.php 961 eval
/showthread.php 28 require_once
Warning [2] Undefined property: MyLanguage::$thread_modes - Line: 43 - File: showthread.php(1617) : eval()'d code PHP 8.0.30 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/showthread.php(1617) : eval()'d code 43 errorHandler->error_callback
/showthread.php 1617 eval

Solved & Confirmed 0.8c - Game Speed x 0
If you reduce the game speed to 0 and then enter the menu, your game will be stuck at Game Speed x0 until you load a previous game. It doesn't crash the game and it didn't apear to happen in any other Game Speed setting besides 0. Hope you have a recent save...

I just thought it was cool to now have a pause-like button option so now I could get better screenshots. This is the one I captured while playing with the game speed and watching it affect the console dialog; yes, I'm easily amused. Smile I decided to hit + and - alternately until I had the game speed lined up where is was still off screen a bit.

[Image: KkSD.png]
I finally got a chance to sit down and play the new update today for a couple hours. thought the gamespeed change was amazing including the "pause" feature. Such joy coming out of one small feature Big Grin Though I'm glad I didn't try to save it while at gs0 that would suck since I am only running one save file Tongue
Added to the list of Bugs/Issues & Crashes!
I am going back and checking on some bugs that I reported in previous versions to see if they are still an issue, and I found something interesting with this one in 0.8f.

When I try to reproduce this by putting the game speed at 0 and entering the menu which would lock the game up before 100% of the time, now when I exit the menu either with 'Resume Game' or F1 this is not happening. Instead the game resumes back at game speed 1.

Maybe you put a fix for this but forgot to mark it Solved Needing Confirmation Rasmus?
That is what I did Tongue I made a quick fix for it but forgot to mention it. I wouldn't say that it is totally solved yet because it shouldn't go back to gamespeed x1. So I will keep it as a but until it is fully solved.
Solved with the next version!
Just checked this one, but it has the same result. When game speed is 0 going into the menu it returns to 1 after leaving the menu.
Solved with the next version (the 0.8i version that is).
Dwelvers Alpha 0.8i released, this bug is now solved but it need confirmation (from players) Smile
Game speed remains at 0 after exiting the menu. This one is fixed!

Forum Jump:

Users browsing this thread: 1 Guest(s)