Solved & Confirmed 0.8c - Various Creature Equipment bugs
#1
Here is a link to an album showcasing various equipment bugs. If i understand correctly, these should be fixed in a future version but i think it's a good idea to showcase them here.

1. You can get Cyclotaurs to dual wield a 2handed and a 1handed weapon if you put the 2handed weapon in the left hand.

2. You can't get orcs to use 2 weapons at one unless they somehow manage to equip a weapon in the left hand on their own.

3. Creatures can have all kinds of strange things equipped. As you can see i have orcs with ingots for armor, imps with bones and rolling pins. But most importantly of all, my imp Jonathan figured out how to use a great hammer for armor, and he even gains the damage bonus from it. Why can't my orcs do that Smile

3. Even if i have a ton of great equipment crafted, creatures won't equip the items on their own.

ALBUM
Reply
#2
Interesting, I like the Imp wearing a hammer. NICE! Who knew ingots were useful as armor?
Reply
#3
Thank you Smile
Added to the list of Bugs/Issues & Crashes!
Reply
#4
Hmm, I can't reproduce many of these bugs. Did you manage to put the wrong equipment on them, or did they get the equipment automatically? Like after loading a savegame?
Reply
#5
I found all the creatures as you see them in the screenshots, except for the Cyclotaurs, those i equipped myself.
Reply
#6
Then I blame the loading of save games!
Reply
#7
Solved with the next version! The issue was similar to this one: http://forum.dwelvers.com/showthread.php...78#pid9578
Reply
#8
Just noticed while trying to confirm another issue solved, a couple of my Orcs didn't like having a hand free. Check this out:

[Image: KtLG.png]
Reply
#9
Is this from your old savegame? This bug fix don't fix faulty savegames, if the orc had a antroot in his hand because of an earlier savegame from the 0.8c version he will still have one in his hand in the 0.8d version.
Reply
#10
Yeah, it was from a save game that's been used since 0.8b, guess I need to start a new game in this version.
Reply
#11
How about this? Could I mark as solved or are you still experiencing this specific Imp talent to eat with a cart attached to it's body? Wink
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
Reply
#12
LOL Sebt! I think you may have meant that to go on another bug report. Just did another check on this in 0.8f and have loaded my save many times without having any weird things equipped. I don't remember having any other weird equipment after I started a new line of save games in 0.8d so it's been a couple of revisions now. With as many people playing now, I would expect this would be reported if not here, on Steam, so I would say this one is solved.
Reply
#13
Thank you mello Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)