Solved & Confirmed 0.8c - Crash when loading save with threading disabled
I have a super laggy (for me) dungeon that i obtained by starting to mass excavate everything. I played with threading enabled from the start and threading was enabled when i saved.

I get below 1 fps in it. I have a Dell Optimus enabled laptop
GPU: nVidia 525M
CPU: Intel i7-2630QM @ 2GHZ
6 GB RAM, Win7 64 Bit

On to the crash itself.
I have multiple saves from the same dungeon taken at different points in my gameplay. If i load the game with threading disabled all of them produce the same crash (assert fail at line 817 in world.cpp)

Screenshot: HERE
Savegame: 1 , 2 , 3

I tried reproducing the bug by starting 2 new games with threading enabled and saving, then disabled threading and loading the game. Both worked. One of them had the same seed as the dungeon in the savegames.

PS: I submitted multiple bug reports to the forum, all of those savegames cause this crash for me and are links 2 and 3. Link 1 is my latest save of the same world.

Attached Files
.txt   DwelversCrash114-8-6-23-27-49.txt (Size: 19,45 KB / Downloads: 1)
I wonder if the problem is that if you start a game using the threading option, then you have to load the game with threading enabled. I tested with save 3 and I saw the same error you have and crash when loaded without threading, but it loads and plays fine with threading enabled. Was getting between 30 - 39 FPS.
That's exactly the problem, as i said it works with threading enabled but crashes if it is disabled.
Added to the list of Bugs/Issues & Crashes!
Solved with the next version!

Here is the issue. This is the item order in the menu with threading disabled:

Here is the issue. And here is the item order in the menu with threading enabled:

So the items get loaded into the game in a more random order when we are using threading. And my fault here is that I only saved the itemID, which is the order the item got loaded into the game. So now instead of saving the itemID into the game I save the itemName.
so maybe that's why i had a messed up resource bar in my game Smile

At first i had the main resources in the top bar but at some point those changed to something else. I assumed i must have pressed a key by accident that changed what resources show up.
Yeah both the resource bar shuffling resources you select to be shown is not happening now, and a game I created with threading on was able to be loaded with threading off. This one was pretty easy to reproduce before so I can say pretty positively this one is fixed.
Thank you Smile

Forum Jump:

Users browsing this thread: 1 Guest(s)