Solved & Confirmed 0.8c - Possible bug related to changing game speed
#1
I have a huge patch of farm in my dungeon, as you can see in this save:
HERE (you need threading enabled to load it Exclamation )

I observed that as soon as i ramp up the game speed (i went all the way to 9) my farm's production started failing. Grown crops weren't collected and new crops weren't planted either.

This could be caused by the fact that the game because that much laggier for me when i increase the speed. That's why i would like some help with other people trying to reproduce this.
Reply
#2
I think what the problem is that there are way too many active jobs and Imps are being tasked for picking up items on the ground instead of production tasks. I let it run for a while on 9 and while there were slow downs in production it didn't stop altogether. The only stoppage I saw was Beer and Bread, but this was only because the Cookery had gotten linked to a storage room that had no Flour or Antroot, but after linking to the DM production started again. FPS got down to 7, but I would expect so.

[Edit]
So I let things run for a while and I noticed that there was further stoppage in productions. A ran it full speed for a couple hours and I finally noticed something about what was going on. After rampages wiped out all but 13 of my Imps, I was curious to see why. Clicking on them to zoom to showed they were stuck. After building up tiles so they could path to tasks again, they were ultimately slaughtered and I was down to a limit of 10. It seemed too that Imp creation didn't resume until the number dropped below 10, but I'm not 100% sure if that was the case. I also got to see my weird creature timer bar issue, which I hadn't seen since I reported it earlier.
Reply
#3
Interesting, thanks for the feedback. In my game i changed the link to the DM, i forgot about that.

So are you saying that even with the link fixed, you still had production stopping when speeding up the game?

Do you know what caused the rampages? Was it creatures being stuck or just "forgetting" to drink/it or something else?
Reply
#4
It appeared that Imps stop being reproduced, and there were just too many active jobs. Imps were not completing jobs and dropping things instead of completing deliveries. There were times when only a single Imp was assigned to that large farm space which didn't seem right considering how large it is. After about 30 minutes running at 9, I started selling off your mines thinking that there were just too many of those to try and reduce the jobs, but things didn't really collapse until I sold off your Storage Rooms an hour later. Then I finally saw the lag you were, and this is when I really noticed they stopped efficiently delivering food and beer to the Bar Room. Of course the Orcs were the first to get pissed about that and then there was the rampage.

It wasn't until then and almost all your Imps got slaughtered that I noticed that you had 13 Imps stuck, and I had to build up tiles to get them unstuck. So I'm thinking it's not the game's speed that is causing the issue with your game it was those stuck Imps and the game's speed just allowed you to see the production chains crumble faster. That plus Imps were not being generated to handle the workload of your dungeon.
Reply
#5
Thanks, that makes sense. I still am lacking experience with the game. What led me to the thought that it was a bug was the that as soon as i went to normal speed, my production went back into green.

I would fast forward until it dropped to around 50% and after i went back to normal speed it would return to around 75% withing a minute or so.
Reply
#6
Yeah, but it does appear there is an issue with job assignments and Imp creation when Imps get stuck and can't have a path assigned.
Reply
#7
Added to the list of Bugs/Issues & Crashes!
Reply
#8
Solved with the next version. I actually had a limit for the elapsed time between the frames. If it goes above a half second it is limited to a half second. This to avoid issues like experienced here. So the x9 gamespeed is still enabled, but if the computer can't handle the lagging the game will limit it self to lower game speed in reality.
Reply
#9
New version released, but needs confirmation from the players that it really has been solved Smile
Reply
#10
So far I'm not seeing an issue yet, but I would like to see what happens when I dig out a huge area before saying this one is fixed.
Reply
#11
Ok, so in 0.8f I was just doing some due diligence on the Elusive Floating Root so I was running at game speed 9 watching my Antroot grow, and after about 10 minutes I decided to drop that since it's about time to go home from work. I did however notice that I got a notification saying that my Brewery had Slow Production. I had plenty of Antroot in storage, and the production of Antroot seemed to be flowing just fine. My initial thought is that the game speed may be effecting production, but I would like to look into this a bit further when I have more time.
Reply
#12
I will leave this one be for now then Smile
Reply
#13
Did any more investigation be done related to this bug by anyone else too? Smile
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
Reply
#14
I was looking into this more, and the main issue still seems to be that if you have a large section excavated, then items stop being delivered properly. This behavior degrades further when game speed is increased, and improves when game speed is reduced. I still see that certain items despite what the game speed is aren't being delivered properly like food to tables. This ultimately leads to dungeon collapse if it goes on too long.

Something which could help slightly is that Piggehs have too much responsibility. I have noticed them trying to pick up regular items far away from the DM which is pointless as they move too slow to be able to get there before someone else picks up the item. I also saw in the activity that one was trying to build which seems wrong. Really I would like to see Piggeh only do tasks related to Food/Beer production. So that's Farming, Cooking, Brewing, and delivering/pickup Water, Antroot, Flour, & Beer only.

Also, getting back to food delivery, the worst part here is that food isn't being delivered to tables. I believe that this task is the 'Store' one which is #16 by default or maybe that is a 'Misc' task? I tried placing Misc above Store, but still didn't see food being delivered. If it is the 'Store' task, then it would seem the real issue is that items on claimed areas are taking priority over delivering materials between your dungeon's rooms.

Here is my Save Game. Hopefully that helps.
Reply
#15
Hmm someone else noticed that problem in other thread. Marked this issue as Not solved yet.
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)