Solved & Confirmed 0.8e - Bridges & Reeds semi-unbuildable
I was under the impression you should be able to build bridges anywhere over water. I found a spot that although you can initiate to build, once it has all materials placed there the construction never gets built; and the materials are on shore.

That would be where reeds happen to be. I don't know if in middle of lake this happens, as I only only noticed this along my shore where reeds were.

there is a work around for it though, and that is building a block wall in the spot to get rid of the reeds. This I did in my initial spot an oddly it worked.

However shouldn't placing the bridge do the same as placing a block?

Note: I have tried rebuilding the bridge several times. As well in other spots along the shore with reeds.
Added to the list of Bugs/Issues & Crashes!
I need a screenshot or a savegame with this issue, I am not able to reproduce it myself Sad

Moved to more reports needed!
I'll have to wait until I am able to play the game, as in all the versions since the christmas update so far I haven't been able to much farther than the start menu.

I don't have a backup of the last dwelver version that worked either. However the only save I have worked off of was the one I have given before. Same save but a little bit further along.

That is about all I can give. If memory serves me, it should be in the north east side of the map around water. Where there are a lot of reeds in the water along the edge. There should be a spot near that I made a bridge that use to be reeds; however I had to use the work around, filling in dirt for the reeds to disappear and then make the bridge. So near that one bridge if it is there should be a path I had to dig that goes diagonal north east a few blocks. There are reeds along the edge of them. Each one was unable to build, it was as if the imp started to build and then once did there was no bridge; like they gave up building, as the materials would end up on the floor before the bridge.

I do apologize for the lack of pics, as yes that would be probably be easier to explain, but for the moment I am unable to. Wish I had backed up the last version that worked. Which was e or f.

For me in that version it was reeds along the edge that mainly I could not build a bridge over. Quite possible that it fixed itself, but for obvious reasons I can't check at the moment.
Well I finally was able to play again thanks to the J version.

I don't really know exactly what is going on, but in that same dungeon; even if in an older version it appears now they just don't build the bridges in that area.

[Image: rk4qps.jpg]

I was wrong in it being in north east, it is south east of that map.

The one that is finished, was the original spot that I had to put dirt down first to get rid of the reeds, then placed that order to build it. Only then would that one that you see built gets built.

Now with the other two you see in process of being built, the one on the bottom with 1 string left was the second one I laid down to test, and this is over another batch of reeds that I was talking about in the other post.

However instead of doing what it did before, which was they built and then it disappears when done building leaving materials on shore; this time it appears they don't want to even attempt to build there. So I even laid down the third one top see if that was the case, and that one is not over reeds; it is over clear water.

so I think it may be a bit more than meets the eye on this one. It seems to be only that particular area of water it does this. I have setup of building ques elsewhere and they immediately go, build, and finish the project. These ones I have yet to see them finish in all 3 hours I watched them. Imps seem to go to it then walk back with rope in their hands as if they found it on ground, sometimes stopping short distance from the "work in progress" bridges, and turning back.

Now I don't even really know what is going on, or if it is somewhat just the fact it being started in older version or the bug manifesting in a different way. Can't seem to pin point the exact nature of it.

Also note When I first loaded the map the day before it crashed when it got to the bridge building part, and then crashed a second time deleting the file. Good thing I have a back up; even though I had to redo the newly implemented stuff again. Laying beds for 2 of the creatures, one needed for the cookery, and the other I just had complaints from due to lack of bed. And fixing the production links a bit so it was manageable with out worries much. So after all that, on the next day I got to what I described above with the bridges.

Seems like an overly long endless routine that seems to not ever finish for some reason, when else where in the dungeon I can get them to construct things. I can get them to dig in the area no problems it is just building a wooden bridge in the area that for some reason they are not finishing in timely manner. 2-3 hours for a bridge is a bit much, and the reason I knew it was like that is building a bridge in another water hole they finished it within minutes like a hoard to drop materials and one to construct it.

If you want the error log for the crash I mentioned I attatched it. Although I think that was mainly due to the memory problems I was having with my computer that day. As I did all my actual testing those bridges on the next day when I somewhat solved my memory issue. I only ran the debug on the first crash and not the time it corrupted on save which left a 0 byte file. didn't even start saving.

This is the file being used in the J2 version it is now:

Anyway I hope this helps a little at least with what I thought was originally the problem; might be something else entirely, but is specific to that location.

EDIT: I just noticed in the screen shot it reset the material cost. I'll have to check this out shortly...

Attached Files
.txt   DwelversCrash115-1-13-19-25-22.txt (Size: 18,31 KB / Downloads: 0)
Ok I know was a short time but better with this file:

This is before the second bridge. The other one after I noticed that in the pic, I reloaded #3 and they eventually finished the 2 bridges.

I am going to assume they will finish, however it is taking longer than what I would expect. I noticed behavior of the imps.

Shown easier in the #2 file.

The imps will start here and there, then eventually what makes it take longer it seems is that the imps carrying the materials to the bridge stop short of it, and run back to where they got it from. I managed to get it down a couple resources.

So I guess I can truly say this is actually fixed, since they do build the bridge eventually, at least on the #3 file. I didn't wait long on the #2, as I noticed the behavior that is causing the long build time.

It is fact that this place is a distance from the DM though. It doesn't really take too long for them to get there with the resources, however they seem to cut short in delivering them completely. Like running in circles between bridge and DM (or where ever they are getting the resource.) Not literally in circles but to and fro temperamentally somewhat.

Sometimes they decide the resource they are delivering to the bridge I guess is not good enough quality? Well joke aside that is what it appears, as there seems to be a wait period between trips.

This initial bug was problems building on those reeds you see all over the place in the water. But seems that specific part is solved; albeit a bit slower in that specific area for only wooden bridges that I know of.

They react quickly to digging and building other things on land in the area, just not that watering hole. Thank you for you time as i am sure that is a lot to read.

And can only hope it helps a little in the tuning...Smile
Thank you!

Back to being unsolved Smile
Thank you for the savegame and the bugreport! This issue is now solved with the next version Smile
Version 0.8k has been released, this bug needs confirmation from the players Smile
Sure looks it. They don't run around in circles anymore.Smile

So it is fixed.
Thank you Smile

Forum Jump:

Users browsing this thread: 1 Guest(s)