Solved & Confirmed 0.8f - Autosaving
#1
Auto Save file no longer shows up in the Load Game list. I used F4 to load an Auto Save, and it didn't load the save I created with F2. The progress was further along than where I Auto Saved from.
Reply
#2
Added to the list of Bugs/Issues & Crashes!
Reply
#3
Just wanted to add a bit of information because I think I get what is happening here. When you first try to autosave, this works exactly as it should (at least I have tested where there is no autosave present). The next time you try to use the autosave, it overwrites your main save. What I mean by that is after an autosave, I created a save called 08gN and F2 overwrote it each time I autosaved instead of overwriting the file called autosave. Lost an entire day's worth of design because I accidentally dropped a water tile on the top level of my dungeon, forgot the autosave was broke and expected I would be able to go back to my main save, and now I have a water tile I can't remove that needs to be.
Reply
#4
This is an design issue from my part, the autosave works like if the player has loaded or saved a game through the menu this save game file becomes the default autosave file. This is so that once the player has decided to use a specific savegame he can quickly reuse it with F2 and F4.

This is fixed now, from this point the F2 and F4 will ONLY affect the autosave game file.

Solved with the next version!
Reply
#5
F4 is still loading the most recent save point. I created a new game, saved it as 10, then autosaved, then a bit later after a room was built so I could be sure the load was from the right point, I overwrote my 10 save, hit F4 and the save game 10 was loaded.

I had a previous autosave file, which may have been from a previous version. I don't know if that should matter here, but I will remove it and retry the process.

[edit]
So it looks like there was an issue overwriting the autosave from a previous version because when I loaded the auto save it wasn't from the level I had just autosaved from. Now the file was deleted and autosave is being overwrote properly. F4 is still just loading the most recent save and not the autosave file exclusively.
Reply
#6
Solved with the next version (the 0.8i version that is).
Reply
#7
Dwelvers Alpha 0.8i released, this bug is now solved but it need confirmation (from players) Smile
Reply
#8
F2 saves to autosave.dat only now. Although i'd name it Quicksave instead of autosave, coz it's not atomatic Smile

By the way, option to set autosave to automatically save game every 5, 10, 30min etc. would be nice. Smile
Reply
#9
I also checked to make sure F4 was only loading autosave and not just the last save created. It's working as it should. It would be nice to have the option to make autosaves occur every so many minutes like Ufol mentioned, but I would like to have an option to disable timers too. Could add a checkbox pretty easily to the menu.
Reply
#10
I will put this one as solved and confirmed. The timer option with separated "quicksaves" and "autosaves" needs to be put as suggestions. This is something that have been asked for before, hopefully I will have the time to include it with the next version Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)