Dwelvers Journal 2014.12.29 - Alpha v0.8g is now released
Dwelvers Alpha v0.8g has now been released

Dwelvers Alpha v0.8g has now been released, you can download it at the Dwelvers website.

To download it you need to go to Dwelvers website, then login with your username and password.
Once this is done a new tab leading to the members page should have become available. Here you can download the latest version.

Feature updates in 0.8g
Bug fixes in 0.8g
  • Resolution list empty in the launcher - The resolution dropdown list is empty.
  • Cannon Placement and Rotation - When placing a canon, it will not stay oriented the direction you set it for, and can't be rotated.
  • Creature Name is Very Large - Would this may have to do with a character limit on the name bar. This is a pretty long name that is displayed in large print on the screen.
  • Unequip starting orcs, new item available for production! - I'm still not sure if we should either be able to make basic orc equipment straight away from the very beginning or if un-equipping a starting orc's armor/weapon should unlock that item for production ONLY AFTER we construct a blacksmith.
  • Rally doesn't draw all orcs immediatly - Start new game. Unequip starting orcs random weapon/armor. New item available for production!
  • Shovel - This is a small bug and I don't know if it's a real bugg but when you select a tile with your shovel a imp comes to the tile and start swinging a pickaxe.
  • Dwelvers.exe is not closed - Since the last update i have the problem when i quit the game the dwelvers.exe will not closed and the task are inactiv.
  • Exiting Game - I don't really see this as a bug, but I think when you exit the game it should close off the loader and debugger. It also influence Steam.
  • build queue - Imps are gathering wood for all tables, instead of collecting resources for first table, than second and so on.
  • Crash on startup, game won't launch - So, when I try to launch the game through steam, I get an immediate "Dwelvers.exe has stopped working" with no useful information.
  • Crash Loading Textures (Threading Enabled) - Unexpected error on startup. deleted and reinstalled. The first report is before the delete.
  • Prison Skull Wall Tile Float - Was surprised I could build a shackle on the same tile as a prison door because of another issue which has been fixed. The door was not affected, but look what happens to the Skull Wall Torch:
  • Ladders and Torches - This is really kinda nitpicky, but you know me...I was playing around with ladders today, and fortunately they rotate just fine, but it looks really weird when you have a torch sticking through your ladder.
  • Minions ignoring rally flag - After ralling flag some creatures still are training instead of responding to the call.
  • lack of animation (blueprints) - lack of animation (blueprints)
  • Crash when taking control of a possesed Piggeh - I cast possession on a piggeh and it worked fine until I pressed 2 to assume direct control and then the game froze and I had to use the task manager to kill the process, attached is the crash report.
  • Possible bug related to changing game speed - Speed of game affects crafting selection - I observed that as soon as I ramp up the game speed (i went all the way to 9) my farm's production started failing. Grown crops weren't collected and new crops weren't planted either.
  • Splash Screen Crash (Multiple Monitor Triggered) - While I was waiting for the splash screen to load, I clicked over on my secondary monitor to work on another page, and then got Not Responding then crash. I tried to reproduce it, but after 5 times of following the same steps to generate the crash I gave up so I'm not 100% sure what the cause is.
  • ladders - Not being able to place ladder on solid rock, when there's only level of solid rock.
  • Got some problems, had many error box when lauching the game. And no answer after creating a sandbox. - So I was trying to reproduce another bug I reported earlier, but this one seemed different enough to warrant a separate thread.
  • Prison Skull Wall Tile Float - Was surprised I could build a shackle on the same tile as a prison door because of another issue which has been fixed. The door was not affected, but look what happens to the Skull Wall Torch:

Feature updates in 0.8f

Bug fixes in 0.8f (Sorry for not solving more bugs with this version)
  • The pressure pad will no longer be built in a pressed down state.

Minor feature updates in 0.8e

Patch fixes in v0.8e

Patch fixes in v0.8d
  • Deleted savefile - I was playing on my map for about 8 hours over the last 3 days. I saved my map over 20 times, everytime on the same slot. But today the game crashed by saving, and now my save is gone.
  • Various Creature Equipment bugs - Here is a link to an album showcasing various equipment bugs. If i understand correctly, these should be fixed in a future version but i think it's a good idea to showcase them here.
  • Crash when loading save with threading disabled - I have a super laggy (for me) dungeon that i obtained by starting to mass excavate everything. I played with threading enabled from the start and threading was enabled when i saved.
  • Video Performance - I'm getting this a lot now that I've been playing a while.
  • A Battle Has Broken Out with a Bridge - This is a weird one, and the first time I'm seeing this. So I started a new map and I was noticing I kept getting a message that a battle had broken out.
  • Game froze as I was selling wooden Bridge - I found new and closer fishing spot so I went to my other fishing spot to sell the wooden bridges and game froze as i was selling the bridges...
  • New Creature Timer Bar - Right before a new creature is created, the timer bar that indicates time till a new creature spawns extends past the creature icon to the top of the screen like so
  • Constructions - Mine - same bug as with Impanzze bed on 0.8b.
  • Possession - After hitting F1 and opening menu while using possession, I'm not able to leave creature with esc key - menu pops out.

Patch fixes in v0.8c
  • Surround sound seems reversed or just borked - For all versions of Dwelvers, up to, and including .8b, the surround seems to do what it wants. Objects in center of focus are quiet, while the sides seem reversed. I am not sure if I am describing this accurately. Is this a known bug? This is the only game I have this issue with. Newest realtek drivers installed, openal installed.
  • Hanging on load - With threading unchecked, the game hangs while loading. With threading checked, the game gets to the main menu but hangs while creating a game. I've left it sitting for 10 minutes just to make sure it wasn't simply taking a long time but it just sits there at the "creating game" screen. The music cuts out after a couple of minutes.
  • Confused Orcs in Trainingroom - Some Orcs are confused in the Trainingroom when the door are open.
  • small issues - After selecting Impanzee's bed there's no animation - construction is invisible, untill imps build it. Aslo there's no animation when I choose to feed DM with Impanzee, body simply disappear next her, and she doesn't open her mouth.
  • Rally Flag & Bridges - Rally Flags placed on Bridges fall through to the ground under water and are not visible. Troops do still go to the Rally location though.
  • wrong texture? - After selecting solid rock to be mined, such texture appears. I'm not sure if that was planned, or it's a glitch
  • building queue - It seems that imps are waiting for all resources to be gathered for piece of furniture no matter if it's iron, or leather, before they start gathering resources for next construction.
  • Fog of War Over Water - Issue - water - When you get to a point where you get to a water formation, I think the Fog of War should dissipate at least a few squares over water as you should be able to see across it.
  • Crash to desktop - equipping creatures - Crash - During change armor of the orcs - Game crashes when I put armor(I tested bone and metal) on imps, or orcs.
  • Crash to desktop - Maze? - After opening maze some crashes appeared, not sure what exactly trigger it.

Urgent bugfix in 0.8b

Some of the upgrades since v0.7e
  • AI Test - Upcoming aggression - Enemies can now dig into your dungeon.
  • New creature bars - The player can now see the health, the level, the mood and the name of the creature, and a lot more clearly than before. Also, with this design it is a lot easier to separate friend from foe.
  • Console window - A discreet console window has been implemented that updates the player when a new item is available for production, when a creature level up (showing the name of the creature as well so that the player bond a little more with them), when the player gets a new message (battle or production), when the player speeds up or slows down the gamespeed (yes, we can now modify the gamespeed with +/- within the range of x0 -> x9).
  • Easier to obtain creature info - When a creature icon is selected with the hand some other icons will pop up above it. These icons shows how many of the creatures are in a good, neutral, bad or dead mood. Also how many of the creatures that are idle, working, or fighting. When these icons are left clicked the player will toggle and zoom in on these creatures.
  • New creature production system - The idea is simple. There will be some buildings in the dungeon that attracts certain creature types. When these buildings are built the creature that are being attracted will get spewed out by the Dark Mother. From this point the player will have to make sure that this creature (lets say Orc) is happy. Because when all the Orcs the player owns are happy a timer will increase (that is the cyan colored line in the screenshot above), but when one Orc of all the Orcs is unhappy the timer will decrease. This is represented by a green (+) or a red (-) as seen in the screenshot. The challenge here is to keep all the Orcs happy, and the more Orcs the player gets the harder it will be to keep them all happy at once.
  • Dwelvers XML Config - From here the player will be able to choose building costs and creature attraction if he wants to experiment with the balance of the game.
  • Gamespeed can be tweaked between x0 - x9 with the + / - keyboard button.
  • Difficulties can now be chosen after a level has been selected, it is no longer the level that choose the difficulty.

Patch fixes since v0.7e
  • Unreachable enemies, ignored rally flag - They saw the enemies below first then I discovered the portal and flag it for the orcs to smash, but they are too busy spiting and pissing on the impanzees below (I don't blame them, with all the beer they drink...)
  • dwelvers.exe is not closed - Since the last update i have the problem when i quit the game the dwelvers.exe will not closed and the task are inactiv.
  • Water bug - While digging around a lake the water started going crazy, showing intermittent waterfalls, that would build up and then disappear continuously.
  • Broken hidraulics on maze - Apparently Cyclotaurs aren't the greatest engineers...
  • Can build prison door into oblivion - I was building a proper settlement for the poor cyclotaurs to recover after being freed from the maze, when I noticed that prison doors can be built to be opened into nothing...
  • Torch inside statue - When you build a Orc statue on top of a torch on the wall, the torch does not disappear.
  • Crash When Placing Room Flag Over Idle Imp - The game crashed while moving the flag for a newly built store room. I'll post the log file, if I can find it, shortly.
  • After storage room separation - ....I preferred to keep the two storage rooms and devided the huge one. At this point the first one had all its old settings, but the second one was just the old storage room without flag or sign. As I tried to set a new flag to the second storage room, the game crashed.
  • Can't sell lilypad - You can't build blocks over lilypads, so I can't claim that block if the water is too deep, thus, I'm unable to build enough dirt to completely level a lake and use the space to build rooms..
  • Rally Flag & Bridges - Rally Flags placed on Bridges fall through to the ground under water and are not visible. Troops do still go to the Rally location though.
  • Can't destroy final Cyclotaur door - So i discovered a Cyclotaur maze. Everything went smooth, but when i reached the final door my minions won't destroy it, like shown in the Screenshot. After reloading and restaring the game, nothing changend.
  • Delivery flag crash - i increased the size of an already big sorage room the delivery flag location changed and when i put it back to the old location the game froze.
  • Crash after hit F1 in ceature menu - When I press the F1 Button in the creatures Screen, the game will crash.
  • Imps eating with the Cart - I don't know if its a issue but my imp eating with the cart...
  • Imps with cart sometimes keep working in packaging - sometimes imps take a full kart and start filling another instead of going straight for the portal.
  • Feeding loop - it creates somewhat of a loop of imps carrying the stuff back and forth ( takes some time after the order is placed
    the first few items work fine )
  • Feeding orders dont seem to be saved - I saved a game where i had a huge feeding order going and and the order was ogone after loading to test for another problem.
  • (Black) Blocks, not rendering wall faces under construction - It is different, it changes with the angle and its only when the wall block is under construction.
  • Ogg crash - Game crashed with the message that the Ogg file were being unable to load.
  • Confused Orcs in Trainingroom - Some Orcs are confused in the Trainingroom when the door are open.
  • Crash - During change armor of the orcs - I have this crash when i change armor of the orcs or of the imps. .
  • Selecting where to save makes the list scroll just below said savefile - There's a weird glitch with the scroll bar when saving.
  • Can only lock doors with the rotate option - Left clicking on the doors does nothing, where previously it would lock it. You have to use the rotate option for it to lock the door with chains and padlock.
  • Shield decoration has a black/transparent background on *some* rooms - The bug happens in some Rooms in some not. Shackles and painting seem to behave OK, it's only with the shield.
  • Shovel - This is a small bug and I don't know if it's a real bugg but when you select a tile with your shovel a imp comes to the tile and start swinging a pickaxe.

If you want to contribute with ideas:

Just make sure that you read the post of already suggested ideas so that you don't double post. And there are also some layout requirements for the suggestion posts that you need to follow to make it easier for us.
Link to the "The list of already suggested ideas"

If you want to report a bug or issue:

Just make sure that you read the topic about the already known bugs and issues so that you don't double post.
Link to the "Known bugs / issues Alpha v0.8"
Thanks for the update and thanks for working over the holidays to give us content. My FPS seems to ave improved dramatically but i don't know how to open the debug menu any more so i can't tell for sure. Big Grin

The first time i created a sandbox on normal after the update, the game crashed but i was running it in borderless windowed using BorderlessGaming so i'm not going to report it unless i get it without it running.

In the same line of reasoning can you please post a list of all the keys and what they do (for example i see almost all the F keys do something and it's not documented). As well as the new debug menu and whatnot. Also what happened to the threading button? it seems to be missing from the launcher.
I guess dev mode and cheats have been removed from the distro now? Can't remove fog either so that's what I'm assuming. I had stopped using that as much as I was, but it was nice to be able to open things up when speed-clearing.

Still gonna have loads of fun with this. Bugs beware! I'm comin to find you.
Ah, use "ALT+T" to open the tools menu.
Just learned that I can't put Wall Manacles on my Prison Wall anymore, kinda disappointed. I was thinking that Wall decorations had changed so that they can only be placed on blank walls since it looks like you can't place em anywhere besides empty claimed tiles.

Forum Jump:

Users browsing this thread: 1 Guest(s)