Solved & Confirmed 0.8g - Materials textures
#1
Stone is glowing and coal is shining.
[Image: 9ieq7p.jpg]

Edit:
[Image: 21awpzd.jpg]
Reply
#2
This is very weird, somehow I believe it has something to do with the way the textures are loaded. That some color textures get the wrong specular mapping. I tried reloading the game a couple of times and discovered a minor glitch with this. Does this texture bug appear every time the game is reloaded?
Reply
#3
Yes, it occurs everytime I reload the game.
Reply
#4
...I thought that this was with the Christmas spirit of things...Blush
Reply
#5
Another texture bug:
[Image: 4v1w0p.jpg]
Reply
#6
Uhh don't touch it, it may be radioactive! Big Grin

Anyone else noticed that as well?
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
Reply
#7
I haven't seen this one myself, but I wonder if I used a widescreen resolution if that would make a difference.
Reply
#8
The fish in the water also glow...I'm now afraid of feeding them to my minions... for they could mutate and rebel, just like the impanzees!!! The resolution I use is 1280x960.
Reply
#9
This one has now been solved with the next version!
There were several issues that was causing this, first off the mipmapping was a little wrong, and the specular textures got loaded in the wrong order so that they didn't sync with the color textures. For example, if the items gets the specular texture like a lamp, then they will be glowing a lot. The mip-mapping issue on the other hand could make it so that the uv coordinates of a rock texture for example could glide over to another shining specular texture making its edges glow, or making a black line for edges.
Reply
#10
Solved but need confirmation!
Reply
#11
Not solved yet.
[Image: 2jeojcw.jpg]
Reply
#12
Thank you Smile
Reply
#13
I hope it is solved now, I can't reproduce it. But I believe it has something to do with the wrapped icon texture reported here: http://forum.dwelvers.com/showthread.php?tid=1313
As all the textures gets tiled into one big texture in the game when they are loaded, it may just be so that one incorrect loaded texture could destroy it for the rest of them.

Solved with the next version (0.8j)!
Reply
#14
Version 0.8j has been released, this bug is solved but need confirmation Smile
Reply
#15
That one is solved.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)