The following warnings occurred:
Warning [2] Undefined variable $unreadreports - Line: 66 - File: global.php(961) : eval()'d code PHP 8.0.28 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/global.php(961) : eval()'d code 66 errorHandler->error_callback
/global.php 961 eval
/showthread.php 28 require_once
Warning [2] Undefined property: MyLanguage::$thread_modes - Line: 43 - File: showthread.php(1617) : eval()'d code PHP 8.0.28 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/showthread.php(1617) : eval()'d code 43 errorHandler->error_callback
/showthread.php 1617 eval

Solved & Confirmed 0.8h - Loader doesn't display all cards
This is on my laptop where I have the basic Intel HD Graphics 4600, but it also has a Radeon HD 8690M which the game should be using for best performance. The Radeon doesn't appear in the list.
Check if there are a control panel for your graphic card where you could add Dwelvers.exe as an exception for using the high performance graphiccard.
This is of course an issue, but I really need to know if it is solvable somehow through an option in windows.
I forgot from reading your post earlier regarding nVidia cards and switchable graphics, so after seeing your comment here I went into my Catalyst Control Center for my Radeon card, and I changed the settings so that while plugged in it uses Max Performance, and under the Application Settings, (Dwelvers.exe was already there) I switched it to Max Performance, but it still doesn't show up in the list of cards in the loader.
Wasn't sure if should make new topic as this one is pretty much what is happening.
Similar to above except nothing is showing in the 3 top boxes in the loader. It just says EMPTY in each of the 3 areas:
Graphics adapter, output, and resolution. Drop downs being blank.

Intel® HD Graphics (is what the intel graphics panel says)

Trying to play with just the empty bits obviously came up with an error box:
Error location: TmpSaveDriverSpecSettings
Message: Screen settings could not get adapter!

That is when steam is loaded.
When steam in not loaded and booted directly from the dwelvers.exe, Loader pops up with:
The first box reading "Microsoft Basic Render Driver" and that only being selectable in the dropdown.
The other 2 are blank like mentioned above.

Same error popup box when trying to play.
I think I know the reason to this one, in a couple of hours I will send you a pm with a patch fix for this. If it works I will make it official.
I have sent out pm to Mello and Tamorr with the fix, could you tell me if this solved the problem?
k, despite crashing in creating a game, at least now with that it gets to the menu screen. Smile

And does show my card and all spaces are filled with roughly correct info. The display was the only one that looked a bit different than what it did before, but that is ok since it basically states what it is; which is: \\.\display1

Makes me think that is almost a mac/linux way of putting it. But is what it is, as I only have 1 display.

So in short it does work to in the very least get to the menu. I really aught to try creating a map without the browser running...>< like I usually do. Regardless thank you that helps quite a bit.Smile
Unfortunately, mine is still not showing the Radeon card. I don't know if it has do do with me using a docking station or what. If I can find some time I'll check and see if there is anything posted out there about card switching for this laptop. Maybe there is a newer driver that could help. I'm starting to dislike my Radeon boxes...
Was the card visible with the previous version?
I have removed all the obstacles that could have caused this issue. If it worked in the previous version it should work in the upcoming. Solved with the next version!
Dwelvers Alpha 0.8i released, this bug is now solved but it need confirmation (from players) Smile
I'm still only seeing the Intel adapter in the list, but when I look at the monitoring in the Catalyst Control Center it shows that Dwelvers.exe is set to High Performance. I'm at least able to run everything on High detail now without it crashing so I don't know if that was an issue with the onboard card, or if it is now truely using my Radeon adapter.
If you press Alt+T and then choose "Game Performance" the card that the game is using will be written down. Is it still the Intel card?
Yeah, the Intel card is still the one that is listed. Now I don't have it hooked up to my docking station at the moment, and I can't remember if that has a more powerful power adapter, and possibly this 90W adapter isn't strong enough to switch to the other card. I'll check again tomorrow when I'm in the office.


Just checked while in the office where I have my 130W adapter. The game still says it's running on the Intel card.
Okay, so I have been working on this one for a while now. I have read some of the NVidia documentation and there I found a setting I could do in the code to enable the high performance graphic card without forcing the user to go to the nvidia control panel and set it manually. So I restored the settings in the NVidia control panel and ran Dwelvers, noticed that I couldn't get fullscreen any more with the high performance graphic card, then I put the code in as described in the "NVidia documentation" and restarted Dwelvers. This made the game automatically enable the high performance video card.

I have some issues finding a solution to your problem Mello because usually the graphiccard is visible at least Sad
Anyway I hope this solves the issue.

Solved with the next version!

Forum Jump:

Users browsing this thread: 1 Guest(s)