The following warnings occurred:
Warning [2] Undefined variable $unreadreports - Line: 66 - File: global.php(961) : eval()'d code PHP 8.0.30 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/global.php(961) : eval()'d code 66 errorHandler->error_callback
/global.php 961 eval
/showthread.php 28 require_once
Warning [2] Undefined property: MyLanguage::$thread_modes - Line: 43 - File: showthread.php(1617) : eval()'d code PHP 8.0.30 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/showthread.php(1617) : eval()'d code 43 errorHandler->error_callback
/showthread.php 1617 eval

Solved & Confirmed 0.8i - Runs a while then errors, then windows forced close and Crash
Basically like I mentioned in the other threads, but since I don't know if is the same or not I posted anew.

Basically the same thing happens visually; The game runs till hits the start menu, and a short wait, then freezes up. The exception though is the error boxes this time that pop up with and without the debug tool running. Also I've tried in full screen mode and does the same, but at least eventually the windows is quicker to close the program; unlike last time, which I had to literally take the battery out in order to reboot the system. (Although in hindsight I probably could have ctrl-alt-del to do that at that instance.><)

One of the errors that pops up is:

1. Error location: D3D::UtilMap
Message: Failed mapping resource!
(an ok box)
[Image: 23m0gec.jpg]
Which is the first of 3 different popups.

2. is usually some texture not loading and asks to retry. This one is different everytime I try.

3. is a runtime error.

After #3 windows pops up to close program, so I proceed to do so.

Both debug info are low settings with my prefered resolution in windowed mode.
Show Content
This one I tried with V-Sync checked
Show Content

Once again my system:
Gateway laptop (ne56r48u)
Intel B960 processor (dual core 2.2ghz)
Intel HD Graphics
4gb DDR3 RAM

Hope this helps, as I have noticed something else when first started laucher; which will be in a separate post...
Added to the list of Bugs/Issues & Crashes!
Okay, so the "UtilMap" function in this case is used when the game is loading a png image and reading its content just so that it later on can tile it into a bigger texture so that the game don't have to many texture swaps.

The "Map" function which it is really called in Direct3D10 - 11 seems to have some issues with certain graphiccards and when it is being threaded, so to eliminate the "Map" function and all the questions about this I downloaded an external library to load the png files into the game with the same result.

Solved with the next version (0.8j)!
Version 0.8j has been released, this bug is solved but need confirmation Smile
Thank you.

Now it does run, even was able to create a new dungeon with it.Smile

So safe to say, I believe, this has been fixed. Figured it had something to do with how it renders image to things in game. compatibility due to the graphics card I have. That was very informative.
Thank you Smile Marked as solved and confirmed!

Forum Jump:

Users browsing this thread: 1 Guest(s)