Solved & Confirmed 0.8i - Imp AI: Production stuck
#1
Hello.
Recently i encountered some strange bug. Namely - after closing breach to quickly cut off portal one imp was left at the wrong side of the wall. After some time i realised that all my production stuck.

At first i thought some of storage settings was bad, but whatever i did, including selling every storage, didn't change a thing.
I saw roots and flour piled on farmland, but no imp was taking it away - thus cookery halted production and there was no food in my dungeon. When i sold tile with items on it, then imp took everything to storage and then to cookery. But again, no more roots or flour were taken from farms.
Workshop had zero assigned imps - there was smelters, iron and coal, but no work was done there. Imp were only standing around in place guarding unfinished buildings.

After i break wall again and let lone imp inside, suddenly all got back to normal. Metalworks began production immediately, and roots was storaged properly as well.
I think there was some glitch in imp AI that caused production breakdown while That one was cut off.
I fortunately made a savegame before i let that imp back. The issue is all the same everytime i load the game. Everytime things go the same. When i opened breach and build wall immediately - even before imp goes back, things go back to normal again. When i cut off another imp after releasing first, there is no change.
The problem is it's not easy to reproduce it on new map. I doesn't happen everytime imp is cut off, but still when it happen, it generally breaks your dungeon. I'm not sure what happened to that imp, but it certainly was linked to broken AI issue.

Savegame Here

This is that little fellow who broke it all.
[Image: CNjqLqm.jpg]

Halted metalworks...
[Image: vU5W6Yw.jpg]

Halted farm...
[Image: jBmKTox.jpg]


EDIT:

Managed to reproduce glitch (accidentally again). Scenario is generally the same. Imp got trapped at the wrong side of the wall. After some time (when items overflow flag at falmland) all other production halted. Situation got just like before. Imps only dig, claim and build. The main thing i noticed is that imps just stop gathering any items from rooms - items from regular floor are storaged properly, from rooms are untouchable. Also links, and item prefferences set to storages seems to be ignored. After releasing imp, everything goes back good.

And, imho, while production stucks, all other things just get slow. Even transporting fish to bar rooms gots slow... i see pile of fish near mother room, and only 1 or 2 from time to time are taken to the bar room.

Another Savegame Here

Devious imp again:
[Image: 8onCsj9.jpg]

Dungeon view - lots of stuff untouched on the floor, full farmland and empty bar room and metalworks. Storage cluttered with coal and stone instead of food which is linked there.
[Image: XS2SAD7.jpg]
Reply
#2
Thank you for the detailed explanation, I will look into it as soon as possible Smile +3 to you Wink

Added to the list of Bugs/Issues & Crashes!
Reply
#3
Hmm, so it seems the rooms don't un-assign when they can't reach the room :S
Could you resend the savegames? I think they got removed because I took to long Sad
Reply
#4
http://www.filedropper.com/saves

Here you go
Reply
#5
Downloaded! Thank you Smile
Reply
#6
In my last game i found another aspect o this bug. While trying to trigger another bug.

I dig up large square. Then cut it off with few imps inside. I orderd to fill whole area with one layer of dirt. Imps built up only one row then stood still until i opened area again. Selling and placing blueprints again made imps build few more but they got stuck again very soon. So it seems its not only related to rooms but i think every task.
It might be its easier to reproduce than i first thought. I'll try to mess with it a bit more.
Seems they dont realise they are cut off.
Hope it bring some more light to it.
Reply
#7
Thank you! I found the issue and it is solved with the next version!
Reply
#8
Version 0.8k has been released, this bug needs confirmation from the players Smile
Reply
#9
I tried to reproduce this by locking out my Imps from access to the Farm or DM. There were 2 Imps left to work the Farm and deliver so I don't know if that's verification enough, but the farm continued to produce. May want to give this a bit more time before setting as solved. Would like to get a big area cleared out on one of my saves since that seems to have broken things before.
Reply
#10
Understood, UfoL, what do you think?
Reply
#11
I couldn't manage to reproduce this so far. Seems it's solved. May want to play with is some more, just to make sure.
Reply
#12
Great thanks. Smile
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)