Solved & Confirmed 0.8k-2 - Crafting Production Halted
#1
I want to give Tom the credit for finding this one since he asked a question here which prompted me to go check this out. So what is happening is if you craft an item that requires more than one item to make, the items will be delivered, the Imp assigned to the job will load up the items to the crafting device excluding the final piece, but then won't pick up the last item if it requires multiples spanning several resource types to complete the project. The one exception to this is the Iron Fist. I think the only reason this item which requires 2 Iron to make doesn't halt production is because all it needs is Iron and not another material of a different type.

[Image: XxDD.jpg]

So in this image I have queued up all the items that require multiple resources. What is being worked on is the Bone Armor (3 Bones + 2 Rope) and the Leather Armor (2 Leather + 1 Rope). You will notice that the Sewing Machine and Anvil have some of the components delivered to it, but the remaining components are next to the flag. I ran this a second time queuing up crafting items one by one to watch what is happening. So in the case above, the Imp will deliver 2 Bones and 1 Rope to the Anvil, but leave 1 Bone and 1 Rope on the ground. Similarly with the Leather Armor, 1 Leather and the 1 Rope is delivered to the Sewing Machine, but the final piece of Leather remains on the Metalworks floor.

So +2 to Tom for finding this one!
Reply
#2
Thank you for this! I will check it out Smile
Reply
#3
Solved with the next version!
Reply
#4
Dwelvers version 0.9 released, this bug is solved but need confirmation.
Reply
#5
This one has been resolved. Tried a couple multi-quantity items in crafting, and all were made.
Reply
#6
Thank you Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)