The following warnings occurred:
Warning [2] Undefined variable $unreadreports - Line: 66 - File: global.php(961) : eval()'d code PHP 8.0.30 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/global.php(961) : eval()'d code 66 errorHandler->error_callback
/global.php 961 eval
/showthread.php 28 require_once
Warning [2] Undefined property: MyLanguage::$thread_modes - Line: 43 - File: showthread.php(1617) : eval()'d code PHP 8.0.30 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/showthread.php(1617) : eval()'d code 43 errorHandler->error_callback
/showthread.php 1617 eval

Solved & Confirmed 0.7e - The elusive floating root
I don't know, I kinda find em's definitely one of those quirky things I get a laugh out of when I see it. Just had a lil chuckle after seeing it still in 0.8i.
Haha, they are hard to trigger, sometimes I see them, but then I am not in "debug mode" and can't get all the info I need about them. So I try to solve it best I can, but I can't confirm it, only hope that they will not come back again Tongue
If we could get those autosaves with a timer option, then it could be possible for us to get you a save game right before one occurs if we catch it fast enough.
I will try to get that one in there Smile
i noticed strange and funny thing... elusive floating... bag of flour... and some coal... plus some other random stuff. It seems they started to rise up from storage room shelves, and sometimes from some randome places where imps dropped them. While playing with water i found out that it reset item height when flooding.
I'll try to reproduce it and get some savegame.
Unfortunately i cant get any screenshot in present version - every single one is blank white sheet Sad
maybe that will help to find out what causes it, or should i make new thread about it?
If more than one item rises from the tile it may have to do with the water level. Perhaps the items thought that there were water there even when it wasn't :S
Ok, so I think I may have finally captured this in a way that will be helpful. In other instances once the root was harvested, I didn't see it return. In this save however, it keeps coming back from the same location. Maybe this will help.

Here is the affected tile:

[Image: UJ7Z.jpg]


So apparently when you load the save the roots grow normal again. Back to being 'Elusive'...
I think this might be related to this: - The elusive floating root
But posting it anyway because it's not the exact same scenario

I was building a HUGE farm, because i wanted to farm, and some of the roots, started to get in the wrong places.

[Image: cW53aIR.jpg]
[Image: AEnlv53.jpg]
3570K@3.8GHz|MSI GD-55 Z77|2xGTX 770|Corsair 32GB DDR3|Corsair 86W|Fractal Define R|2 TB HDD(3x)|240 GB SSD|H100I
Current record holder of:
Most fish stored at once! (5202x)
[Image: ghqnARY.jpg]:heart:
This is the same issue as the elusive root! Lets see if I can merge it with that topic...

Seems like I merged it in the wrong direction... Oh well, same result Tongue
Yes! It's still alive and well!
See that weird little shadow beside the cursor?

[Image: kQPbe3e.jpg]

YEP! you know it... it's the elusive floating invisible root!

EDIT: There's a second root below the cursor, not visible on the image. I've uploaded the save file if anyone wants to mess around.

.zip (Size: 2,83 MB / Downloads: 0)
Nice! Haven't seen a shadowed one before. I noticed some floaters back in 0.9b, but the problem is you can't get the roots to float from a save game. I've tried a few times.
One day I will catch that little bugger Tongue
[Image: Zzip.jpg]

I loved those books when I was a kid if you catch my reference. The Elusive Floating Root kinda reminds me of him. Fun spotting one in 0.9d.

[Image: Zziq.jpg]
Had to look twice myself Tongue

Forum Jump:

Users browsing this thread: 1 Guest(s)