The following warnings occurred:
Warning [2] Undefined variable $unreadreports - Line: 66 - File: global.php(961) : eval()'d code PHP 8.0.28 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/global.php(961) : eval()'d code 66 errorHandler->error_callback
/global.php 961 eval
/showthread.php 28 require_once
Warning [2] Undefined property: MyLanguage::$thread_modes - Line: 43 - File: showthread.php(1617) : eval()'d code PHP 8.0.28 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/showthread.php(1617) : eval()'d code 43 errorHandler->error_callback
/showthread.php 1617 eval

Solved & Confirmed 0.9 - Selecting blocks to mine does not select all
Randomly when i was selecting anything around this block, it seemed like one of the blocks just wouldn't show as selected.
But when i released left click to initiate, it got selected anyway. Works in inverse aswell... and it is independent of vertical position, and its just this one block

I do not know how it got this way, but here is the savegame:
before selecting
[Image: iwMViCh.jpg]
After selecting
[Image: PX6t8VA.jpg]
Removing selection:
[Image: HnBvPAT.jpg]

That's the only affected block
3570K@3.8GHz|MSI GD-55 Z77|2xGTX 770|Corsair 32GB DDR3|Corsair 86W|Fractal Define R|2 TB HDD(3x)|240 GB SSD|H100I
Current record holder of:
Most fish stored at once! (5202x)
[Image: ghqnARY.jpg]:heart:
Thank you Smile

Added to the list of Bugs/Issues & Crashes!
So I found the issue. It had something to do with that you can't dig anywhere where there is something to sell. And as certain jobs can be sold (such as constructions, path claiming, reinforcing walls) this can cause some problems.

This was a little bit of a teaser for me. I removed the issue with not being able to dig where there are certain jobs and that solved it. But I wanted to know what invisible job it was that were in the way, and then I found it...

It was the enemy that was building a rock block there (enemy construction sites are invisible) Tongue


This has been solved with the next version!
Dwelvers alpha 0.9b released, this one is solved but need confirmation!
Yeah, who could help with confirming that? :p
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
I don't see how you could really reproduce this besides using the original save game. I loaded the save game provided and it didn't experience the issue that was happening before. In the process of trying to reproduce this I did notice something else regarding selected tiles. It seems that sometimes when combat is engaged, that a once selected tile becomes deselected. I was randomly loading maps and selecting large areas around the DM to excavate, and on a couple I got results like this:

[Image: Z3pn.jpg]

I ended up running seed 52 over and over again selecting out an 16x16 space around the DM. Of course only a 12x12 area can be selected first off until they dig out enough to add another row to dig, and after reloading this seed around 15 times, only twice did I get a block to deselect. Each time was when combat started.
I will look into this other issue and return it to unsolved.
Solved with the next version!

The only time I could reproduce it was when a creature was moved to a location by the player (when selecting a creature and then moving him to a specific location). When this happens he stops doing the job he is assigned to (just as he should), but the problem was that not only did he get unassigned, the whole job got cancelled as well. So if we had an orc that was going to dig out a block, and then gets moved by the player, then the dig job on that block got cancelled. This could also be seen with the rally flag from times to times.
Dwelvers 0.9e released, this bug is solved but need confirmation Smile
As far as I can tell this isn't happening anymore. I tried the conditions you had found could cause the problem, and it didn't unassign the job.
Ok, I will mark it as solved! Thank you Smile

Forum Jump:

Users browsing this thread: 1 Guest(s)