The following warnings occurred:
Warning [2] Undefined variable $unreadreports - Line: 66 - File: global.php(961) : eval()'d code PHP 8.0.28 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/global.php(961) : eval()'d code 66 errorHandler->error_callback
/global.php 961 eval
/showthread.php 28 require_once
Warning [2] Undefined property: MyLanguage::$thread_modes - Line: 43 - File: showthread.php(1617) : eval()'d code PHP 8.0.28 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/showthread.php(1617) : eval()'d code 43 errorHandler->error_callback
/showthread.php 1617 eval

Solved & Confirmed 0.9e - Minions won't take items from rooms to Storage
Creatures aren't taking any items that are on top of room tiles to Storage. I only see them take things that are already in store to rooms or to build and only pick up items that are on the dirt only. If I want them to take something from say my farm I would have to delete the tile under the items. Also I took over some catacombs and they didn't pick up the items that were on top of it either. CCXI said on steam forum he was having the same issue after the patch too.
I believe I am having the same issue. Since updating to 0.9e, I've noticed that my beer production doesn't work. Minions seem to stop farming, and stop moving what they had farmed previously to storage, so beer and food production both stop. I sat and watched my farm for about 15 minutes and while some imps would occasionally wander in, they wouldn't do anything or move anything. Room flag is placed in the clear and there are paths open to storage (which has capacity) and the cookery room. Never observed this behavior in 0.9d (the first version I played).
Added to the list of Bugs/Issues & Crashes! I will probably make an hotfix out of this. Do you have a savegame I can load with this issue?
I'm afraid I do not, sorry. Sad I'm still playing the demo version (though I'm grabbing the full version on Friday).

Played again and the hangup seems to occur with the antroot ... it stacked up at the farm room flag. The imps never moved it into storage. Eventually one got moved to the cookery and I got a single unit of beer, but that was it. I did get some bread. Finally farm production stopped because there was no room at the flag.
Np, I have found the issue and now I am working on solving it. Will try to get an hotfix up there today.
Hey Jackal, hey Rasmus.

Anyone else have blocks (and items and farmland) turn red and then start to get the black cracks as if its being dug or attacked? I just played a new creative game, (wanted to try building a storage room right at start to see if it stopped the production didnt, but things looked good at first) Around when the production bug starts to happen (15mins in?) I noticed the frequency of the red blocks of death increased, and then once production was completely backlogged and imps wernt doing shit, the red blocks were popping all over the place every few seconds.
By the way, the red blocks of death would stop suddenly, before the crack graphics completed. And the cracks would slowly fade away.
CCXI, actually I have seen this but I just assumed it was that I was close to some lava that was causing this. Like some buildings and room tiles suddenly turn red and sometimes set on fire for a bit?
I have found and fixed the issues, this includes the passive imps, and the water bug. But I did also find another issue with the backpack not working as it should, so the creatures only picked up one item at a time from the ground instead of filling the backpack.

I need to do some play testing before releasing the next version. It would be very embarrassing for me if I released another version like this without checking it properly.
I have released the 0.9e-2 hotfix version now. Please confirm if this issue has been solved with it Smile

Solved but need confirmation Smile
It's still in my game. I started a new game and my creatures never take anything from rooms to store. Only if I delete the room tile from under the items will they go pick them up and take them to store. :|
I'm seeing it as well. It is halting production and even keeping constructions I have set to build in the save from being built.

Save Game
I too am having this issue.

I would upload my save file where things are going strange, but i do not know where it is.
It seemed to be fixed for about a hours worth of play instead of 15mins. But somethings still not right.
You are right, I found that the issue was with the backpacks, when a bunch of items was transported from one storage room to another only the first item that the imp was holding in its hand got unmarked as not needing to be transported further, the other items that was laying in the backpack and got moved to the new storage room still had the "mark" that they should be transported to the same storage room that they were put in.

An item that has the "mark" to be transported to a storage room will not get another "mark" to be transported another storage room, it is just laying around waiting to be moved to the same storage room that already exists, and the imps don't do that.

So... Solved with the next version Smile

Forum Jump:

Users browsing this thread: 1 Guest(s)