The following warnings occurred:
Warning [2] Undefined variable $unreadreports - Line: 66 - File: global.php(961) : eval()'d code PHP 8.0.28 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/global.php(961) : eval()'d code 66 errorHandler->error_callback
/global.php 961 eval
/showthread.php 28 require_once
Warning [2] Undefined property: MyLanguage::$thread_modes - Line: 43 - File: showthread.php(1617) : eval()'d code PHP 8.0.28 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/showthread.php(1617) : eval()'d code 43 errorHandler->error_callback
/showthread.php 1617 eval

Solved & Confirmed 0.9e - Random water annomalies
    started up a new game on easy to test latest build 9e.

saw some water nearby but not overly close. excavated my first room deep like i normally do to gather 200 wood, within a block of the water. accidently somehow got some water enter the excavation when digging out a root on the side wall (there was no water directly opposite that wall) which was strange.. don't have alotta time at the start before the orcs get thirsty, so quickly filled it all in, and worked on the other rooms.

started working on the 2nd room and cave in.. really close to the starting area.. thought that wasn't supposed to happen.. the cave in revealed water (from an underground lake maybe??) certainly didn't show in my initial scout of the unknown. Didn't havve time to fill it all in so just made the rest of the room bigger and got to work gettting the rooms setup. As i was setting up the other rooms i started to see some water annomalies.. such as a column of water blocks appear and sink into the floor.. or occasionally a block of water on the floor then disappear.

i built the last of the 4 starting rooms, the bar and was busy building the chairs at the tables when suddenly the room got flooded with a raised fountian type water source in the centre of the room, which then proceeded to flood my entire bar.. ughh.. something is definately wrong here.

added the save file for you to check out. err scatch that.. its 22mb.. lets see if i can do a screenie... err not sure how this insert into post thing works.. preview of it doesn't seem to work.. guess i'll just have to post and see if that works.

I had something that sounds almost identical happen to me on 0.9e. One game the water appeared to center around a well, so I thought there might be some new flooding mechanic at work. Later it happened in a random, top level spot in the dungeon. Then again later I had a (again, top level) farm that had lava seeming to fall onto it from above with no explanation.
Added to the list of Bugs/Issues & Crashes!
Just to let you know, those save games compress very well so the best option is to put it in a zip file and share it via DropBox, Google Drive, or what have you. A zipped save game isn't much over 2MBs.


Got a chance to play today, well try to as it seems 0.9e is really broken. I think this issue stems from water sources that are in the surface world above where a cave-in happens. I noticed when I tried to go above ground to investigate, the portals flooded and I was able to see that water was over the cave-in tiles that keep flooding. I know the maps are auto generated, but there really needs to be some conditional statements added that prevent water/lava formations from occupying the same space as portals.

On second thought, I tried a new map, and this one was much worse. Got above ground, and there was no water above the incidents. It looks like 0.9e is going to be mostly unplayable. Sad
Solved but need confirmation Smile
So far I haven't seen these crop back up yet after playing a few different maps. It seemed like these were spawning all over the place before no matter what seed I tried. I think you got this one fixed.
Thank you Smile

Forum Jump:

Users browsing this thread: 1 Guest(s)