Solved & Confirmed 0.9e - Fullscreen Failed
Got this today when I tried to load a game:
[Image: attachment.php?aid=232]

Windows 10
No crashes reported in debugger, and now this happens every time I try to run the game...

I'm running a Nvidia Gforce GTX 960 Driver version
Windows 10 Professional 64 bit
8GB Ram
Processor: AMD Phenom X4 945 3.0GHz

Attached Files Thumbnail(s)
Do you have multiple graphiccards?

Added to the list of Bugs/Issues & Crashes!
(23-08-2015, 10:18 PM)Rasmus Wrote: Do you have multiple graphiccards?

Added to the list of Bugs/Issues & Crashes!

Only the one. No onboard graphics.

I should elaborate on the steps that brought me to this:

1. Loaded a game just fine.
2. Noticed that camera would only scroll up (direction not elevation)
3. Tried to navigate by clicking on a different location on the minimap
4. Fullscreen failed message

Hope that helps.
I have managed to get the game running back on fullscreen, but now, if I try to alt-tab out to look at the internet (which I did trying to troubleshoot this issue), fullscreen will crash again.

This may be a windows 10 thing...
Could you check if this issue is in the 0.9e-4 version as well? I did make some changes with the last versions.
Worked until I Alt-Tab...

Still failing. I noticed that when I try to go back to the game, I get limited motion from the ingame cursor. It won't go far enough down to click the 'leave this level' button. I have to hard close it from task manager.

It seems like it has already switched to windowed mode (hence the limited cursor range), but still shows full screen. It at least tries to recover now back to full screen, which it did not do before.

Attached Files Thumbnail(s)
This is still happening btw.
Thank you, I will try to find a solution for it with the next version.
Okay, so I have read up on this a little bit more, unfortunally I have not caught the exceptions the game generates when fullscreen fails. My guess is that it has something to do with this:

There are many reasons why a windowed-mode swap chain cannot switch to full-screen mode. For instance:
The application is running over Terminal Server.
The output window is occluded.
The output window does not have keyboard focus.
Another application is already in full-screen mode.

I did notice that I didn't set the focus to the game before setting the fullscreen mode, and this could be the cause of it. So hopefully it will work with the next version. If it doesn't then at least I will have more information generated with the fullscreen failure.

Solved with the next version!
Dwelvers Alpha 0.9f2 released, this bug is now solved but need confirmation (from players) Sleepy
Ok this appears to be solved. I can alt-tab in and out fine with no problems.

Forum Jump:

Users browsing this thread: 1 Guest(s)