The following warnings occurred:
Warning [2] Undefined variable $unreadreports - Line: 66 - File: global.php(961) : eval()'d code PHP 8.0.30 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/global.php(961) : eval()'d code 66 errorHandler->error_callback
/global.php 961 eval
/showthread.php 28 require_once
Warning [2] Undefined property: MyLanguage::$thread_modes - Line: 43 - File: showthread.php(1617) : eval()'d code PHP 8.0.30 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/showthread.php(1617) : eval()'d code 43 errorHandler->error_callback
/showthread.php 1617 eval

Solved & Confirmed 0.11.2 BT - Dark Mother Won't Export Resources
I have my DM set to export all resources to the storage room yet she still retains items. Been stuck at 62% for quite a while and only decreased by 2% after running the game at 9x for 5 minutes.
Mello have you tried to save and load the game? Sometimes some functions doesn't work properly if you were playing since map generation and never load the game. Sometimes Imps do not build something till you load the game or sometimes walks between two places in a loop doing nothing other than walking till you load the game, so maybe that's because in your case they won't export any resource? What kind of items still remains in your DM?

Rasmus I also have the same problem as Mello, even after loading and restating the game. I wanted my Imps to export resources like Antroots, Beer and weapons like Knight's Hammer from Dark Mother and from one of my storages, I checked if there's some room in Storage Room to make it possible, and that there is not a single "red arrow of exporting" that blink on these resources - all was good. Because Imps have something like a queue of tasks already it may took some time to get them to work with exporting resources from DM to Storage Room. I also noticed that Imps were exporting resources still after I even lock export of certain resource, but after a while they stopped to do it.

Results? Interesting is that and leather were not exported from either DM nor Storage Room to another storage. Antroots and Beers were exported, but not Knight's Hammer and all other weapons as well as leather too. Is it because crafting items cannot be exported and leather because it's an item that can be only obtained from dead enemies, not produced or dug?

EDIT: Strange, I could export Beer from DM to my Storage Room, but I couldn't export Beer from Storage Room to DM. For Antroots I could do that. I thought it may have something to do with linking rooms with "chain", but nope.

Attaching save file:

Attached Files
.zip   Test 112BT (Size: 2,94 MB / Downloads: 1)
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
Added to the list of Bugs/Issues & Crashes!
This was a though one.

After a lot of research I found that weapons and armors never got exported, and that the reason for this was because they had an active equipping job assigned to them and therefore they were not assigned to the storage room itself. Why equiping jobs are not assigned to storage rooms is because all creatures should be able to equip weapons and armors, not only those that work in that specific room.

Anyways. The result of this was that they first got the a transportation job to another storage room, but then the transportation job got canceled because it didn't belong to any room, so it got spammed back and forth. And to not overload the CPU I've made it so that the storage rooms only assigns about 10 items for transportation each frame. Which results in that if a storage room has about 10 bent swords to be taken out of the storage room then it will assign those 10 swords to be transported, and then the next frame they get un-transported, and the frame after that they get assigned for transportation again and so on.

So all the storage room did was to assing and un-assign the bent sword for transportation and never had the opportunity to assign any other item for transportation. And therefore the transportation halted for all items.

This bug is solved with the next version!
Interesting. What do you mean by frame? It's possible to give two jobs to weapon items, so transportation more prioritized over equipping? I only wonder if there were about 80 weapon items to transport how long would it take to move them all from one storage to another? I assume workers will only move 10 items at once, than do next tasks queued after moving these items than get again 10 items to move.
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
In the storage room the storage itself can have either a transportation job or an equipment job, but not both at once.
The item itself is then holding a pointer to what job it is assigned too, meaning that it don't own the job itself, but knows about it.

So when the player then choose to transport an item out of the room the item gets a pointer to that job.
Then the storage room reads that the item is assigned to a job and should therefore give the item a transportation job to that room. But somewhere along the way the equipment job didn't get canceled by the storage room, and because it didn't get canceled the transportation job got canceled as well.

This is just a broad explanation of what is going on, and to be honest it takes some time for me to get it right myself. So every time you find a storage system bug it is usually pretty complicated to solve because there are a huge amount of parameters to consider so that i don't break anything along the way.

A frame is each time an update is made. So if you play at 60 fps, then 60 updates are made a second. So if it assigns 10 transportation jobs a frames then it assigns 600 jobs a second. As long as this number is higher than the amount transportation jobs being finished a second the player won't notice any difference. And this is only per room, so if you have 10 storage rooms the game itself handles 6000 transportation jobs a second.
I understand now, thank you for explanation. Will do some tests when new version come out. It will take "some" excavations too fully test that, but it will be worth it. Cool
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
Version 0.11.5 BT released! This bug is solved but need confirmation!
This one is definitely solved.
Thank you Smile

Forum Jump:

Users browsing this thread: 1 Guest(s)