Not solved yet 0.11.3 - Resources not loaded on Loading Docks in Trade Routes & connection issues
It seems since 0.11.3 version I can't load resources onto Loading Docks even if I have enough resources and linked Storage Rooms properly.

Also for some reason having more than one Trade Route turned on, makes even disconnected from other Trade Routes Loading docks in different trade Room being prepared to load with resources that belongs do other trade than this room is connected to. See pictures.

Here I have two portals claimed and two Trade routes added to trade queue:
- First portal is on the left side of the picture, Trade Room connected with roads to it is 2x3 built one tile next to Portal. Trade for this portal was unlocked for Stone --> Wood. I built for this Trade Room 3 Loading Docks
- Second Portal - right-upper corner of the picture and Trade Room a the bottom-right side, trade route for Antroots --> Fish. I deleted a road that would connect two Trade Rooms near doors, so it wouldn't bother second Trade room with first trade route. Here were also 3 Loading Docks built.

Moreover, I made a small trade to see how will roads be distributed and for some reason one of the cart in the first Trade Room wasn't assigned to do the task, but a cart from second Trade Room - in which as you can see the other card is being prepared for being load with Antroots like it should be. If I however choose for example to make more than 3 full cargo trades for first trade (> 3 x shift + left mouse click) than Loading Dogs in second Trade Room will not show Antroots for Fish, but Stone for Wood. So if I choose to fill up 6 loading docks with only first trade than in the second Trade Room all Loading Docks will be filled with Wood for Stone - so there will be no Loading docks that would do second trade route, no Fish for Antroots for me.

P.S.1: Since new info bar were implemented I cannot see which portal have been assigned to what Trade Route now, like we could see before.

P.S.2: In previous version where Trade Routes worked normally I had once situation where an Idle Imp that was assigned to Trade Room went to dig tile with his cart (unfortunately I haven't got screenshot for that... BTW remember when were Imps eating with the Cart? Big Grin)

[Image: 24xfjgg.jpg]

[Image: 2dgt2yg.jpg]

[Image: 35lxkq9.jpg]

EDIT: It may be related to Storage room item export / delivery mechanism fault spotted in Can't Craft Items report.

Attaching save file:

Attached Files
.zip   Test 2b (Size: 2,91 MB / Downloads: 0)
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
Added to the list of Bugs/Issues & Crashes!
Solved with the next version. This is the same issue as with the anvil not crafting items.
Version 0.11.5 BT released! This bug is solved but need confirmation!
It's solved.
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
Thank you Smile
In 0.11.15 BT resources are delivered to Trade rooms, however they still can be loaded into docks or another Trade Room, even if that another Trade Room is not connected to correct portal.

For example I have two trade routes stone --> wood, beer --> gold.
If one of trade route (let's say stone --> wood) have more items assigned than number of carts available in that connected to portal Trade Room - game than choose carts from other Trade Room that is even not connected to the only portal that have been chosen to trade stone --> wood.

If even that another Trade Room is out of available carts than the second trade route is not being operated at all, because all carts are occupied which outnumbering trade route stone --> wood.

Here's the save file so you could check this out. Just add more stone to trade route stone --> wood and you'll see there's no room for second trade route, so beer --> gold.

PS. Previously we could see what trade route was made for certain Portal - could we have it back again?
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
Ok, back to being unsolved.
Since 0.11.18 version where "Trades are no longer fixed for each portal, you can now make all types of trades with all portals" the only issue that left is the allocation of resources to certain Loading Docks which now are not assigned in proper proportion (some trades are not even assigned to Loading Docks).

I think this issue can be marked as solved and confirmed, however I highly recommend to look at the issue I talked about in thread called At least 1 cart guaranted for 1 type of trade.
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy

Forum Jump:

Users browsing this thread: 1 Guest(s)