Solved & Confirmed 0.6b - Shovel
#1
This is a small bug and I don't know if it's a real bugg but when you select a tile with your shovel a imp comes to the tile and start swinging a pickaxe. I think this needs thought it must be a shovel.
Pyramid of Live
[Image: kEbemdH.png]
Reply
#2
It will be fixed.. I don't want to treat this is a bug, the pickaxe is more like a placeholder for the shovel for now..
Reply
#3
And it will keep being a placeholder in the next release, it is added it to the list of Bugs/Issues & Crashes, but it will be solved in future versions.
Reply
#4
Solved with the next version Big Grin
Reply
#5
So guys, can you tell there are no problems with this Shovel bug? Smile
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
Reply
#6
Still looks like they are using a pickaxe in place of a shovel.

[Image: KiD9.png]

Now they are bending down instead of standing upright as they would when pickaxing the wall. It would be cool to see them whip out a shovel instead.
Reply
#7
Yeah, but before I fixed this they were standing up and digging just like they would do when digging on a wall. I believe the issue wasn't that the pickaxe/shovel, but that the imps was digging into thin air.

Is it okay that they use a pickaxe? I know that the topic was about that they didn't use a shovel, but I sort of half fixed it, and are now wondering if this feels realistic enough to be marked as solved Smile
Reply
#8
Well I guess it is solved if it was a matter of running the wrong animation. If you don't have the shovel animation as an Imp holding a shovel and instead just bending down with a pickaxe, then that's good but it would be cool if they actually used a shovel.
Reply
#9
True, lets not just ignore that idea, I will put this one back into the "Will be solved in a future version" Smile
Reply
#10
For the sake of cleaning up the bugs reports list, maybe the whole 'Add Shovel Animation' part could just be placed in the List of Ideas & Suggestions?
Reply
#11
Solved with the next version!
Reply
#12
I'm confused on this one. Was it that you intended on putting this on hold till a shovel animation was added, or just that Imps digging down show they are digging down in the animation instead of standing upright while digging?

If it's just the 'digging down' animation and not adding a shovel instead of a pickax, this one is ok. Still think a shovel animation for digging down would be cool.
Reply
#13
But I will have to say that this one is solved, when this bug was up the imps had the same animation for digging forwards as downwards, and that looked a little odd. But now it is fixed. We could add a shovel later on, but not now Tongue
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)