Solved & Confirmed 0.6c - Load/Save water placement bug
#1
I'm surprised nobody's posted a bug report about this yet, but there seems to be a fundamental flaw in the load and save feature. When I saved the game there was no water in the area circled in blue, and the imp circled in red had no path to get to it's present location, so it could not possibly have been there.

After loading the game later, I found water had been incorrectly placed in a dry area, and the red circled imp I mentioned earlier was in an unreachable location, which it was not at earlier.

I've also had issues where I order something built, and if I save the game while the construction graphic is still there, then load it, the construction order has disappeared. So the location of the construction projects appears not be be getting saved at all, and the locations of objects also appears to be getting stored incorrectly, causing them to appear in the wrong locations when loading a saved game.

[Image: 12891279205_540b45270a_c.jpg]
[Image: 11619898803_7d3a89e6bd_n.jpg]
The Golden One!
Reply
#2
I have noticed something similar lately, but I didn't want to bring it up being this close to the next release. I had noticed when I returned to a saved game where I had dug out an area adjacent to a waterfall, that when I loaded the save the waterfall was now coming out of the wall which wasn't before I saved. Also it seems that torch positions are regenerated on a load. I miss being able to place and sell those...
Reply
#3
So water physics need to be fixed as usual Wink

Yeah, the reason I removed it so that the player couldn't put out torches himself was because of the game current inability to select and rotate/sell specific objects on a tile. This will be something I will take a look at soon.

I discussed it a little here: http://forum.dwelvers.com/showthread.php?tid=690
Reply
#4
It's not just water physics that's a problem. Construction sites also do not save, try ordering something built, save the game, then load it again, and you'll find that the project is gone. Creature locations also do not reliably restore upon load, when I posted that earlier bug report where I had a couple of imps getting stuck, I think that's how they got stuck in the first place, when I loaded a saved game, it placed those imps in a disconnected area, an area it should have been impossible for them to get to. If you take a look at that isolated imp circled in red, you'll see he's in a disconnected area, when I'd saved that game there were NO IMPS in that area, there couldn't be, there is no route for them to get there, yet when I load the game, suddenly there's a trapped imp there. How did it get there? The most logical reason is the game did not correctly save that imp's location, so when I loaded it, that imp was placed elsewhere then where it had been when I saved that game. Meaning there is some data that's not being saved correctly, or not being saved at all, that the game needs restore a saved game properly, meaning everything is exactly as it was when the game was saved.
[Image: 11619898803_7d3a89e6bd_n.jpg]
The Golden One!
Reply
#5
I think this thread: http://forum.dwelvers.com/showthread.php?tid=567
Has something to do with this.
Pyramid of Live
[Image: kEbemdH.png]
Reply
#6
Yes, I agree, that "Imps Behaving Oddly" incident was the one I was referring to when I mentioned that I've had this happen before, with imps ending up in impossible to reach locations upon loading a saved game. I'd say that other topic, even though I didn't realize it at the time, was really being caused by a Load/Save bug, which I'm guessing either no one else noticed until I posted a topic specifically about it, or others did notice it but for some reason never posted a bug report about it.

Either way, I posted this in a new topic because I felt the Load/Save issue was going under everyone's radar and would not be addressed unless someone posted a bug report about it in a new topic.
[Image: 11619898803_7d3a89e6bd_n.jpg]
The Golden One!
Reply
#7
I added the construction sites not being saved to the list of Bugs/Issues & Crashes. This is actually something I was aware of, but I think it is for the best I add it to the list so that I don't forget it Smile
Reply
#8
How about objects like creatures and water not showing up in the right places when loading a saved game? IMO that also needs to be addressed as it's effecting game play.
[Image: 11619898803_7d3a89e6bd_n.jpg]
The Golden One!
Reply
#9
Yeah I had an Imp yesterday loaded next to an Overworld portal practically starving before I realized he was stuck in there. Out of curiosity, how are the positions of creatures and constructions handled now when you save the game?
Reply
#10
HMM, I'd call this a pretty big bug if it's causing creatures to die, especially when the materials needed to make their replacements are finite. This could create an unwinable game not because of bad strategy, but because of bug-caused losses.
[Image: 11619898803_7d3a89e6bd_n.jpg]
The Golden One!
Reply
#11
The creatures position is saved, then when the game loads again they get placed onto that same location. The only thing that could get them to move is if the dungeon is different when it was saved from when it gets loaded. And this brings me back to the water physics, because the water don't always get to be in the same location when saved as when loaded. I will start a topic soon so that we can discuss on how to change the water physics.

Even if you say that there were no water nearby, I feel strongly that the water still can mess up some things without the player knowing it. First I will fix the water, then when that problem is eliminated we can see if the creatures position still get relocated.

The building constructions is just plain "jobs" but visible in this case, and no jobs are saved with the save game, so this is something I will take care of as well Smile
Reply
#12
Well I think it can be the water because I had 2 imps stuck when I was building my pyramid 1 was not around water at all and one was around water, only the one around water got messed up.
Pyramid of Live
[Image: kEbemdH.png]
Reply
#13
That makes sense, both times I've noticed this bug have been near water. This bug I also had water suddenly appear where there shouldn't have been any. So it seems to me that not only are the water physics buggy, but it's location does not always save correctly.

Is it also possible that creature locations are not being saved correctly? That sometimes the game outputs the wrong data to the save file?
[Image: 11619898803_7d3a89e6bd_n.jpg]
The Golden One!
Reply
#14
The water physics and graphics has been removed and rebuilt. This issue is solved!
Reply
#15
What about creatures being restored to the wrong location? That was also part of this issue, which I take to be more of an issue with the load/save system then just the water physics.

I've also been having issues where a creature will be on the wrong side of a wall after loading a saved game, in a spot that is unreachable, so it couldn't have possibly just wandered in there, it had to have been placed there upon loading the saved game.
[Image: 11619898803_7d3a89e6bd_n.jpg]
The Golden One!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)