Solved & Confirmed 0.7 - Crash When Creating Game (Seed related crashes)
Dwelvers Alpha 0.7b has been released with this bug-fix, confirmation needed!
So far I have tried at least 10 different random seed numbers, and have yet to have the game crash while building the level. I did get this error once:

[Image: HGhw.png]

If you click ignore it proceeds to generate the map.
Tried several times now to start game with seed 22222. Game crashes.
So I am getting a crash on level creation. It seems to only happen when using a seed starting with two zeros. Ie 00818, crashed my game every time.

Error report.
This is a different bug than the last one. I will get on it Smile
This bug is new and wasn't included in the 0.7 version, it has connections with that I enabled rooms to be connected to each-other as long as their height difference was less or equal to zero.

The problem here was that when the game calculates what tiles are included in the room area it made all the height comparisons from one tile and not from the neighbour tile. This is a mayor mistake from my side, and the result is that when the game calculated what tiles it is that belongs to what room the result could vary depending on what tile it made the check from. And this caused ripples of unexpected behaviours through the code that resulted in crashes. Hopefully this issue can explain some of the other bugs reported here as well.

I made a image here explaining it more visually. The numbers on the tiles is the height of the tile. Lets assume that all the buildings on the tiles are storageroom.



Forum Jump:

Users browsing this thread: 1 Guest(s)