Solved & Confirmed 0.7 - Multiple Instances of Dwelvers is Loaded from Launcher
#1
I have noticed this multiple times now, but when I load the game from the launcher I have 2 instances of it running instead of just one. Anyone else seeing this?
Reply
#2
You mean that when you press "play", you have one "launcher" and two "dwelvers" icons in the taskbar?
I know that the splash screen produces an extra window, but this one should be invisible in the taskbar, and it should disappear when the splash screen disappear.
Reply
#3
No I mean literally 2 instances of Dwelvers. At first I thought I was hearing things because I kept hearing the intro music overlaid the normal map music. I Alt + Tab'd to find the Game menu on the second one which was the source of the intro music. I then Alt + Tab'd to my running game in the other instance. Closed the other instance so intro music would stop looping in the background.
Reply
#4
Hmm, weird.. I will look into it, even if I can't reproduce the bug I put up some safety-nets to prevent this from happening.
Added to the list of Bugs/Issues & Crashes.
Reply
#5
I found out what is happening here. When a crash has been generated, after saving the log I would close the debugger. With the launcher still open I was hitting the Debug button not realizing that it launches the debugger then the game, and I was clicking on the Play button after clicking the Debug button. I guess I got to used to having to launch those separately.
Reply
#6
Ah, I see..
The thing is that the game has a saftynet for this implemented already, it checks if there are any other Dwelvers windows open, and if there are it will self terminate.

The problem is that after I added this saftynet I added the splashscreen, and the splashscreen don't count as a dwelvers window. Meaning that you can spam the play button and start an unlimited number of Dwelvers games up until that point that the spashwindow closes and the dwelvers window opens.
Reply
#7
Solved, fixed so that the debug and play button gets disabled until Dwelvers starts running.
Reply
#8
Awesome! Thanks
Reply
#9
Dwelvers Alpha 0.7b has been released with this bug-fix, confirmation needed!
Reply
#10
It's mostly fixed. I can't launch a second Dwelvers, but now there is an annoying message that pops up each time saying 'DwelversDebugger is already running!' and I have to click Ok. I verified that it is in fact only running one instance of the Debugger and that a Debugger process wasn't already loaded before using the Launcher.
Reply
#11
I will return this to not being solved.
Reply
#12
Solved!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)