Dissected & Moved 0.7 - Crash when creating new game
#1
Hi, Just saw that you want bug / crash reports here so this is a duplicate of what I posted in the announcement topic for Dwelvers 7:

Game crash.
I set all my settings, then went into sandbox easy, chose a new seed number (entered 1965 if that matters), pressed enter and then run map.

Game immediately crashed.
This was in the info box:
Code:
Problem Event Name:    APPCRASH
  Application Name:    Dwelvers.exe
  Application Version:    0.0.0.0
  Application Timestamp:    5388aa34
  Fault Module Name:    Dwelvers.exe
  Fault Module Version:    0.0.0.0
  Fault Module Timestamp:    5388aa34
  Exception Code:    c0000005
  Exception Offset:    001173c3
  OS Version:    6.1.7601.2.1.0.768.3
  Locale ID:    1033
  Additional Information 1:    0a9e
  Additional Information 2:    0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:    0a9e
  Additional Information 4:    0a9e372d3b4ad19135b953a78882e789

I can run the sandbox easy if I do not change the seed number. At first I thought maybe it was because I chose a seed number of only 4 digits instead of 5, so I tried a 5 digit seed number (19655) but it still caused the game to crash while it was saying "creating game" up on the screen.

Edit to attach crash report


Attached Files
.txt   DwelversCrash114-4-31-9-7-54.txt (Size: 17,54 KB / Downloads: 1)
Reply
#2
Thanks for the report Smile

This is the same bug as here: http://forum.dwelvers.com/showthread.php?tid=831
Only that you got the crash while Mello got it to freeze.

It has been solved with the next version Smile
Reply
#3
Also after about 30 minutes of play I got an assertion error, unfortunately i was not playing on debug mode so I have no log to add to it. Something about C++ assertion error, (abort, retry, quit) but I had no choice but to hit abort at which the game closed out.
Reply
#4
Okay, ran it with the debugger active until I got the C++ crash again, so attached is the newest log of the crash

As for what I was doing in the game, really I was just looking around. I did NOT go to the surface world which I see somebody else had gotten an assertion error from starting the game on the surface world but I had not even visited the surface world as far as I know.


Attached Files
.txt   DwelversCrash114-4-31-9-50-47.txt (Size: 17,95 KB / Downloads: 0)
Reply
#5
I started a new game,

As soon as I had placed down a red flag the game crashed with the following log attached


Attached Files
.txt   DwelversCrash114-4-31-11-37-43.txt (Size: 17,95 KB / Downloads: 0)
Reply
#6
I merged your thread dear City Builder with this ( http://forum.dwelvers.com/showthread.php?tid=831 ) because you spotted the same problems. Anyway glad you reported it in details! Thanks. Smile
Spec: Win 10, ATI 7800 HD, res: 1280x1024x75. I support The Venus Project & Resource-Based Economy
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)