Solved & Confirmed 0.7 - Iron smelter
#1
the imp starts to make the first iron ingot from the iron smelter.. up to the point of cooling the iron ... then nothing... no one takes out the cooled off iron from the iron smelter and i never even get the first iron made and my game's evolution is stoped. maybe im missing something... btw my smelter is in midle of room and has access from all sides. Started a new game and noticed that if you have iron ingots ordered somewhere like " a training dummy" was affecting my production... as soon as i sold all iron needing items that where ordered
the imp finaly took out the ingot from smelter .... i let em produce a couple and as it looked to be ok i again ordered 4 trainning dummies ....
2 where built since i had let them make a couple of ingots before i replaced my order .... and again the imp stoped taking ingots out of smelter... so from what i saw ... imps will take out iron ingots from smelter only if there are no items ordered that need iron ingots on the map.
Reply
#2
bumping since i added new info to the report
Reply
#3
This issue appears to be a problem with the production chain. When trying to reproduce this error I first couldn't find a problem with Ore refinement. Then I ran out of Iron. The cooled Ore now sits in the Smelter and isn't being removed. I next dug out a large section of Iron as I thought that the problem was that since I didn't have enough Iron to mix with Coal to refine the Ore. This didn't get my Imps working on Ore. After the Imps gathered up all the Iron so that all I had left was Wood on the mined area, I stopped production on Wood, and now my Ore is being refined again. The 2 Imps I had left over for tasks and are not assigned to a room were now delivering and recovering items from my Smelter gather point. As soon as I enabled production on Wood again, those 2 stopped assisting the Smelter to go gather the Wood on the floor and Ore production came to a halt again.

On a side note, it would seem that allowing an Imp assigned to a room to go gather their own materials from the linked store room would fix this problem.
Reply
#4
I have to give you a +2 for that one Lotanis, it was a very good observation that the issue only arises when constructions was being built that required the same material as the being produced.

@Mello: Hmm maybe.. Lets get these issues fixed first, then we will see if we need to remake the system Smile
Reply
#5
Solved!

This was a really big issue, thanks again Lotanis.

The thing was that when a buildingsite is requesting items, the buildingsite searches the rooms and floortiles for items that the buildingsite needs. The buildingsite is allowed to reserve items that is laying on the ground, or is stored in storage rooms. Items that is laying on the ground has a job connected to them, and this job is marked with "PickUpFromGround", this is so that other jobs with items that can be picked up (like the iron ingot from the iron smelter) don't get treated like a pick up from ground job. What I did wrong was that I forgot to check if the job was a "PickUpFromGround" job, meaning that the iron ingot in the iron smelter got reserved by the buildingsite. And because it was reserved by the building site the imp working in the metalworks room wasn't allowed to pick up the item, and the imps that was going to fetch the item to the buildingsite wasn't allowed to pick anything up from a building inside a non-storage room.
Reply
#6
Happy to help and kudos for the great work!
Reply
#7
Dwelvers Alpha 0.7b has been released with this bug-fix, confirmation needed!
Reply
#8
I have tried orderring items built needing iron before making the iron and my imp was not affected and he or she did make the iron. Later tough when i ordered some hide armor made. my imp made 2 hide armor then all production stoped in the metalworks room. the imp placed some leather/hide on the sewing machine to create the 3rd hide armor but he does not finish the process and the leather just sits on the sewing machine and same for the iron. it sits in the smelter.. all then is stoped in the MR until i cancel the hide armor then the iron production restarts. tried many other times at diffrent points in my game to reorder hide armor and it is always a metalworks room stopper. Edited: made 2 new worlds and had no problems using the sewing machine or the blacksmith station the imp worked and completed thier tasks but i noticed that the items in Q did not go down after one was made .. so if i ask for 1 hide armor the imp will make it but the Queue stays at 1 and he keeps making some. same for all i tried leather/hide/metal armor barb sword and axe. i shall make an new post.
Reply
#9
made a few more worlds since then and havnt reproduced the prob mentioned above, apart from the queuing issue. and i can confirm that in my last 3 maps I had no problems with iron ... placing items needing iron before starting iron production did not stop iron production anymore... all is well for me with the iron production.
Reply
#10
The other issue you described has been reported here: http://forum.dwelvers.com/showthread.php?tid=882

I will set this issue as solved, thanks!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)