Solved & Confirmed 0.7b - Can't See Menu Text
#16
I still can't see the menu text in 0.7c, but you did mention something about disabling a feature to see if that makes it show up...

EDIT: I looked back on the earlier posts in this thread and found out CNTL+C would be added to disable text clipping, I tried this and it worked like a charm for the menu text at least. I'll test it more thoroughly later on, ATM I'm waiting for a business call and don't want to be distracted by a game that's way too much fun...
[Image: 11619898803_7d3a89e6bd_n.jpg]
The Golden One!
Reply
#17
Haha, okay..
Well that is very good to hear, then I know it is the text clipping that is the cause. I will just have to keep working on it Smile
Reply
#18
One option would be to include an option in the launcher to load Dwelvers with text clipping disabled, and have that option also settable in game, in the graphics options, in addition to the ALT+C hot key combo. At least until you solve why text clipping doesn't work on some machines. I'm guessing it could be a hardware/driver compatibility issue. If so you'll likely see more of this bug when released to a wider audience.
[Image: 11619898803_7d3a89e6bd_n.jpg]
The Golden One!
Reply
#19
That was my first plan, but as there are very little space left in the launcher and that this is a problem that should be solved instead of avoided I went in this direction.
Reply
#20
I've had the same bug as SU. I used Alt+C and it fixed everything including the in game text.
Reply
#21
Thanks bhalucard, it is always good to know that there are others that have the same issue. Just one question to you and SU, when having the "Alt+C" inactive, do the items in the production menu get displayed?
Reply
#22
no the production menu warnings do not display with alt+c off. that's why i was so relieved to see a quick fix so i could play.
Reply
#23
Okay, thanks for your help Smile
Reply
#24
I get the same thing as bhalucard. Most in game text does not display without disabling text clipping.

@bhalucard: What graphic card to you use? I'm wondering if this issue is a hardware compatibility issue, in that some GPUs don't handle text clipping as well as others do.

Oh, and welcome to the forum, bhalucard! Cool
[Image: 11619898803_7d3a89e6bd_n.jpg]
The Golden One!
Reply
#25
I found something that may help.. To render the fonts I use a tool named FW1 Font Wrapper. And according to this https://fw1.codeplex.com/discussions/252849 I found others having problems with no text displaying. The difference is that the they never got the text to render, in your case it only rendered if clipping wasn't used.

Well, what I got out of it is that the issue will go away if I disabled the geometry shader when rendering, and that is what I have done.
Unfortunately I don't have a computer to try this on myself so I am not sure this will work or not, but it is worth a try.. If it don't work I will have to send some .exe files back and forth between me and you SU and bugtest it some more if that is okay by you Smile

Marked as solved with the next version (I hope Smile)
Reply
#26
Dwelvers Alpha 0.7d released. Bug fixed confirmation needed.
Reply
#27
I'm having no problems seeing menu and in-game text. Looks like you got this one, Ras. Smile
[Image: 11619898803_7d3a89e6bd_n.jpg]
The Golden One!
Reply
#28
Ahh, very nice Big Grin Thank you SU!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)